Logic 10.5+ Overbridge 2.0.41 Analog Rytm Template


Fresh from updating the Logic / Overbridge 2.0.37 templates for the AR, here they are for Logic 10.5+ and Overbridge 2.0.41. Many thanks to @dshipp for his Digitakt video that taught me a couple of setup tricks (notably, the alt-click to assign multiple buses at once and the fact that the last stereo track is the audio in, and not unused as I previously had it…)

Elektron removed the 10xMono multi-track plugin variant upon which the previous template depended (though that might have been Apple moving things around behind the scenes). So this is based on the new (and only) 10xStereo multi-out. It’s simplified from the last template in that the Rytm Buss stack has gone – this goes straight from the plugin to 10 audio tracks, and now includes the stereo audio in track (the sampler connections). The Ext In jacks still route to FX as they’ve always done.

There are also no stock logic effects (reverb and delay) or compression in this. That shouldn’t be up to me (though obviously I’ve got my favourite Multipressor or Drawmer 1973 on the bus over here).



Download Logic Pro X 10.5 / Overbridge 2.0.41 template


  1. Unzip the contents of the template to /Users/<your_user>/Music/Audio Music Apps/Project Templates
  2. Connect your ARII
  3. Configure it for Overbridge
  4. Make sure your Audio Routings are either globally off or off with the kit you’re using (or tracks will contribute to the mix twice!)
  5. Fire up a new project based on this template
  6. Record using the Rytm Audio track stack
  7. Automate the Rytm Plugin by setting Latch or Touch automation on Rytm Plugin track; as the track plays, move any knobs you like

Wow thanks for this @rgarner

I seem to have difficulties with this step:
4. Make sure your Audio Routings are either globally off or off with the kit you’re using (or tracks will contribute to the mix twice!)

how do I do this? thanks!

I just tried it out.

  1. I installed the newest version of overbridge and am on the newest logic version (10.6.1), on Mac Catalina.
  2. Selected overbridge in USB config (system)
  3. in audio routing settings on rytm, disables all pads in the ‘route to main’ setting (so 12/12 becomes 0/12)

Then I opened logic with your template.

Weird stuff, first it seems to sound OK when I play pattern, but overly loud and clipping a bit. After a few minutes, everything freaks out and sounds very distorted…

Familiar issue? hope you can help!

So, this seems to be a 10.6 issue.
I went back to 10.5.1, and it works now!

thank you @rgarner

I recorded audio, and got this, which is fine. I did not have to change any audio routing settings by the way. Don’t quite understand why this is necessary? it works fine having both set on 12/12

However, no midi is recorded in the top track. is this normal? Or am I doing something wrong?

see screenshot:

1 Like

I was going to say, I’m still on 10.5 so I can’t speak for 10.6 :slight_smile:

Yes, with everything routed 12/12 to master, it’ll record just fine, it’s just that you’ll find that the stereo FX track (which is really a rebadged Master) doesn’t contain just the FX, it has all the drums all over again, so every drum sound is summing twice to the bus (which is quite loud and loses you a lot of mix headroom). Usually, I want the FX track to only contain the reverb and delay outputs, and I definitely don’t want each track contributing twice – setting things to 0/12 ensures only reverb and delay end up on that FX track.

You can say “well, I want the master distortion and the compressor and they only come through on inputs 1 and 2 so I’ll continue to route everything there to see the results on FX”. And that’s reasonable – but in that case there’s no need to bother with multi-tracking – you might as well just have a single stereo track. Often I do! I use the multi-tracking when I want a specific type of compressor/processing or EQ on each track, and to get maximum flexibility when mixing.

EDIT: I’ve not considered the situation where you might want the hardware compressor on one thing and route, say, just the kick 1/12 to master – and the on-board compressor is so good I might just start doing this on kits that don’t use the reverb or delay… thanks!


thanks! and what about the midi sequence, is that also recorded in logic with this template (the top/upper track?), or only the audio files?

The top track will record MIDI, yes. Frustratingly, not always all of it. You can’t for example, record changes to scenes there (but you can if you add a normal MIDI track). You don’t seem to be able to record program changes (A1 -> C3, for example). But you can automate performance macros and all normal parameters.

Also, bear in mind that the Rytm will record one channel of MIDI per pad (plus the FX track) because you can trigger each pad as a different pitch, and this gets busy if you like recording MIDI and editing the notes afterwards, because you’ll find every note is on C1 and you can’t tell them apart. If you’re not editing the MIDI in the DAW, this isn’t a problem. If you are, it’s a massive pain.

Personally, to get around this when using the Rytm as a pure drum machine, I use the Auto Channel (midi ch 14), which records individual notes on C-2, C#-2, D-2 etc. This will record exactly as you expect, with one pad per note on those notes. The trouble is the Rytm won’t then play them back. I’ve ended up writing a Scripter plugin to translate the auto channel notes back to what the Rytm will play.

WOW this is EXACTLY my problem. its a massive pain indeed, I would like to record a midi sequence with the different pads on different notes. And be able to play that sequence from the DAW and control the RYTM with this… I was hoping this could be done with overbridge, and with your template. So I understand this is not the case…? could you perhaps share the scripter? would be awesome.

I think I posted it here sometime last year… hang on…

Yep, here it is. Copying it below:

A Logic Scripter script to translate incoming auto-channel notes on Ch14 (the default) to individual track channels on note C-1 (Midi 36) follows (this works as a workaround, but isn’t ideal):

  Rytm translate auto-channel defaults into Note/C1
  channel equivalents (works only with default track
  channel settings)

function HandleMIDI(event)
  const CHANNEL_AUTO = 14;
  const NOTE_C1 = 36;
  	(event instanceof NoteOn || event instanceof NoteOff) &&
    event.channel == CHANNEL_AUTO	
    event.channel = event.pitch + 1;
    event.pitch = NOTE_C1;

I used your previous template on my previous computer and all was swell. New system and Ive got as far as getting everything working except the audio is crazy choppy and messed up. like a tremolo from hell. Any ideas what’s going on? Ive tried various buffer sizes down to 64 and restarting both machines several times. Weird thing is, the AR app says at the bottom, " your host audio buffer size is 512 plz use 256 or lower." Is there a setting for this on my computer aside from my DAW? would it affect it?

So it looks like its because Im on 10.6… electron says “If you have already updated Logic to 10.6 on a Mac running Catalina, your Overbridge device can be used as a Core Audio device for multitrack streaming and recording until a fix is available for this.”
Anyone know how to accomplish this?

There is a topic more appropriate to talk about OB on Logic 10.6.

1 Like