Machine Drum Bug?


I have the MD SPS-1 MK1 (non-UW) Im on version X0.7 (unofficial).

I am using two input machines on M3 and M4, if I hold (function) and change parameters on all track and then hit (function + extend/classic) to reset all parameters, the M3 and M4 remain with parameters changed.

For example when I engaged the high pass filter and the sample rate reducer while holding (function), and then press (function + extend/classic), all parameters change accept for M3 and M4 where there would be a small amount of high pass and sample rate reduction.

Does anyone else have this problem, or think i might be doing something to cause this? I have tried re-saving the kit many times but when I press (function + extend/classic), I have the same problem.


just tried your spec, M3 and M4 inp machines reset to saved state as expected.

just checking the usual:

  • with all your “re saving the kit many times” did you perhaps accidentally save the kit with the machines parameters HP and SRR at these positions? reset those params and save again.
  • any plocked trigs on M3 and M4 pushing those parameters? any trigs at all (will need a trig to reset the track)?
  • any external midi CC going in that could be affecting?
1 Like

Thanks for the reply,

I will check the MIDI CC when home.
The parameters are saved at 0, I am sure.
The value on the parameters says it is at 0 but the audio sounds filtered and bit crushed until I change the parameters. When you checked did you use audio or did you just check the value of the paramter.


yes, all reset as expected, visually and audibly.
did you find any other causes?