Massive Problems with OB in Live (Rytm)

Hey folks,

slowly this shit drives me crazy !!! I have massive problems with OB in Ableton Live 9 which prevent me from recording my track on the Rytm! Everytime - after a short or a longer while - Ableton Live stops recording - it simply stops the sequencer! I’ve jammed ahead and obviously - everything is lost and i need to restart. This stopping happens randomly - sometimes it occurs after some seconds, sometimes it occurs after 2 minutes. But it occurs EVERY DAMN TIME NOW!

Needless to say that i am NOT able to record ANYTHING if i cant get a solution for this problem! I tried every hub on my computer i have - it happens EVERYWHERE! newest OB and newest Rytm OS are installed. It happens even when im only recording the main output. Its even worse when i try to record multiple tracks. It started slowly … at first, no problem. But everytime i reconnected the Rytm the other day, those stops occured more often. And now: They occur in every session and i cannot record anything anymore!

Please - guys - do you have any idea what that is? Im not using a dedicated audio interface - i use onboard soundcard. It happens with Asio4All as well as the classic DX Driver.

Any help would be greatly appreciated!!!

Thx in advance. Im stuck here :frowning:

id suspect your computer configuration… what kind of CPU? how much RAM? which OS? when was your last clean install?


System specs:

Core i7 4770k
16 GB DDR3
Windows 7 (x64)
Ableton Live 9.6.2

Clean Install 3 Weeks ago.

From the very beginning i already have like 23% CPU usage when i open the Rytm Plugin. Same with the A4 Plugin. Loading both of them does not increase the Load significantly though. And i have to mention that everything works like a charme with the Analog Four! I have those problems with the Rytm only.

What i also have (but also not from the beginning) is that i dont hear the Rytm as soon as i open the Plugin and the plugin has recognized him. It takes quite a long time (up to a minute or more) until the audio is finally reaching the DAW. The audio comes in perfectly in the OB Control Panel though - right from the start. Switching channels on and off and then re apply solved it in the beginning but not anymore now. I already reinstalled the Plugins several hours ago but the effect doesnt change.

Im out of ideas now. And i need to go to bed :slight_smile: Just wanted to record the work of today and then … what a mess, man :-/

unfortunately I dont even use OB, so I cant really comment beyond the fact that such a configuration with such a newly installed OS should really not encounter any problems as long as you follow the manual and so forth, especially since you have no issues on the other box

however, IMHO the whole implementation of OB is unproven, because of how inconsistent it is as well as the performance overall

so, Im not surprised you are having problems - honestly if I was using OB I would expect problems on a near constant basis, which is one of the reasons I dont use it, the other being im pretty much done with composing on the PC for the forseable future as I just got so burned out on that style of working.

1 Like

One thing to try if you have not done so already and if you are able is to use a USB port that is wired directly to one of the pin outs on your motherboard. The USB ports provided on the back panel of many motherboards are essentially hub ports. I am not sure if this will help with OB, but AFAIK it has been known to help with Access Virus total integration. I am just starting to experiment with OB (with a RYTM and a brand new A4 that arrived a few days ago), but I have written multi-track songs using my VIris TI2 all using the total integration without a hitch by using USB ports that I wired this way.

sorry for the late reply.

Yeah i had the Virus TI back in the days as well. Same computer, same free USB Port on a dedicated Hub. Always worked like a charme with all 3 USB audio streams at once - and i did not even have Latency Problems with the Virus. You can easily check if the Ports belonging to a specific USB Host Controller are in use under the System Prefs in Windows btw. I already took care about that to make sure that the Rytm and the A4 are really connected to dedicated Hubs. And yeah - the Rytm has those problems, the Analog Four works like a charme as well - multi tracked with 2 Streams at the moment. No problem. But latency is there with the A4 as well.

I will try this again on my old Macbook Pro which - to my understanding - has two dedicated USB Controllers belonging to the two ports available. I hope that it will work there. As it is right now i really cannot use the Rytm with OB, thats a shame!

anyone tried a USB3 PCIe expansion card?

think i found a workaround for this problem right now.

I unpaired the Rytm from the OB Control Panel and reconnected it. Now everything works again - for now at least. Sync is still impossible though. No matter which mode i select and no matter the Buffer Sizes: The Sequencer and Ableton always run out of Sync! Thats pretty useless crap … but at least i can record again. I hope this wont drift away again. If this really happens i will deinstall Overbridge and work the usual way again. I dont need stuff i cant rely on !!!

ok, forgot what i wrote above. It doesnt work either !!! The moment i disconnect the Rytm (i.e. turning it off) and reconnect it (i.e. turning it on) i have the same fu***in problems again !!!

So, to sum it up: To make it work - after each damn session!!! - i would need to do the following:

  • open OB Control Center and remove the Rytm from the list
  • uninstall Overbridge
  • change the USB Port of the Cable
  • reinstall Overbridge
  • start Ableton Live
  • load the Plugin and cross fingers until i hear the sound and it works again - for that session

Elektron … you ARE KIDDING ME !!! im done with that shit. Deinstalled; Audio Interface installed, Rytm connected with cables … oh - it works !!! And i dont even have real latency, because latency compensation seems to work as well ^^

Really, as fun as OB may be - but if it is so fu***in unreliable - whats the point with the waste of development time at all then??? I hope that - maybe in 3 years - that stuff is finally working on EVERY SYSTEM. Otherwise Overbridge will be a cheap copy of what Access mastered perfectly with the Virus TI and will therefore be unusable!

hmmm sounds like an audio driver issue not an OB issue. have you tried installing the audio drivers that are provided with your motherboard? I was using the nvidia hd audio drivers and had plenty of issues with OB but switching to the realtek drivers that were recommended by my motherboard manufacturer (asus) solved all issues with latency and compatibility.

havent tried that yet. running the Default Windows High Definition Drivers for that very Soundcard. Maybe i should indeed give this a try, because:

I installed everything on my MacBook now and - what a wonder - it works perfectly there. Same Ableton Live, same Overbridge - no issues! Sound is instantly there, Multitracking works perfectly and there is no Latency - at all! I dont even have to change the Sync to Clock Mode - it is already pretty decent. Changing to Clock Mode makes the Sync Snap on, thats awesome! Buffer Sizes run at 256 Samples in the Plugin and CoreAudio. CPU usage is also very low; just 4% and this is a MBP Late 2010 ^^ With a Dual Core Intel and just 4 GB RAM. Crazy.

Will give your hint a try on the Weekend i think. If its really all about the Driver … but i still wonder why i dont have issues with the Analog Four in that very same constellation. Maybe i need to refresh the whole System after all. Just checked its original Install Date: That Windows is running since December 2013 already :slight_smile:

if you arent using ASIO in windows you can forget about stable audio

you need a real audio IO interface, or at least an ASIO 4 ALL driver (but thats almost as bad)

Sorry for chipping in as I don’t have any OB gear… The Windows MIDI implementation has given me personally a lot of headaches when it comes to syncing equipment, even when it came to simple use cases as sending a MIDI clock to my Blofeld for controlling the arpeggiator. The really infuriating thing was, that on an old Windows machine everything worked, but after getting a new and much more powerful PC it didn’t work anymore. I guess that’s the curse the myriad components which Windows needs to support: bad driver optimisation.

mm… didnt read all replies, but what worked for me.

a) always turn abelton resolution to 48 khz… didnt worked with 44,1
b) i had some sort of recording/stopping issue in cubase… easy solutions is not giving the timeline/transportation data, just clocking it (sorry, dont know how its called in ableton)
c) make sure OB is not listed as sound card
d) on windows… deinstall all drivers, install new and ALWAYS KEEP THE SAME USB-Hub… way back in the days i had lots of windows troubles just by connecting devices to different usb-slots, than the slot i used, when installing the drivers (Windows hell… not really plug and play)