MD MIDI machine controlling MnM?

i’m trying to control parameters on the monomachine using the machinedrum’s MIDI tracks. for example, change a MnM track’s filter and delay settings to specific values simultaneously, which cannot be done by tweaking the MnM’s encoders.

i’ve hooked them up with MD as master and have no sync problems. however the control i want isn’t happening.

basic setup:

-base channel 11, span 6 (which, as i understand it, means MIDI channel 11 controls Track 1, ch. 12 -> T2, etc.)

-kit includes a MIDI-16 machine, which should affect MnM T6.
-base channel: –
-MIDI machine has saved CC messages and values corresponding to the parameters I want to control, per the MnM’s appendix (CC1D = 73 = filter width, CC1V = 22 which is the adjusted value I want for the width, etc.).

however i get no effect on the MnM’s T6 when i unmute the MD MIDI track, trig it, plock it or tweak it manually

anybody see what i’m neglecting here?

Should be OK with these settings. It’s time to troubleshoot connections and settings, I’m afraid.

Maybe you already have these settings but…

you need to select “midi machine 6” for transmitting Midi channel 6 on the MD (you said you selected MIDI-16 machine, which would be wrong machine to use)

Also, check your MD Global Slot “Control” “base channels” & set value to “–” if they are conflicting with your midi machine channels “11-16”

Thanks for the perspective, Peter. After further exploration, it turns out I can use MD MIDI machines to adjust parameters on all MnM tracks easily – except T6. I can’t imagine why this would be. May file a support ticket if I can’t find an explanation.


I filed a support ticket and while troubleshooting with Elektron’s Olle, we discovered that the problem only exists for T6 under the circumstances I described above: Base channel 11, span 6, so that MIDI channel 16 affects T6. If I lower base channel to 10 and use MIDI channel 15 to control T6, everything works fine.

The upshot: It’s a bug, and probably one that will remain with us.

1 Like

Thanks for posting the result. If someone else searches for this issue in future, it will save them some headscratching.