MID machines: "Automatic" Bank Change (CC32) on pattern change

Didn’t find anything on this, so I thought I’d write it down for all MD users that still fancy sequencing external gear:

When using a MID machine, the MD sends out a Program Change when you switch patterns.
Program Change can be selected via PCHG on the Routing page.
To make a Bank Change, you have to dial one of the CC control on the Effects page to CC32 BNKL.

Now here’s the quirk:
When changing the pattern, the MD send the Program Change first and then all the CCs.
Which means you bank change comes after the program change.
Most synths recognise the bank change, but do not put it into effect until another program change arrives.

The workaround I found:
Set both PCHG and CC32 to 0.
Use the first active step of the pattern to p-lock the Bank Change.
Use the second active step of the patter to p-lock the Program Change.

For some reason, it does not work with the Bank Change saved in the Kit and just p-locking the Program Change.
I monitored the midi stream with MIDIOx and in the latter case the bank change is not coming through.

set the freaking notes like this for pattern vhange and it should work^^ in the case you use a DAW for sequencing

I’m not sequencing from DAW and I’m not trying to to pattern change on the MD.
It’s about changing program+bank on another synth.

I’m not quite sure, but I think you will need two p-locks for this bank change, according to CC0=MSB and CC32=LSB plus a third p-lock for bank number. Did you try that?

Well, it works for me the way I described in the opening post (p-lock of CC32).
I’ve tried with CC0 and without p-locks, but that doesn’t change it.

Another suspicion that I have is that the MD can probably not distinguish between CC32 = 0 meaning “select bank 0” or "this parameter is not set, do not send it.

It was a bit late last night when I tried, I will probably investigate some more during the weekend.

thanks from the future! this definitely pushes me to the right direction.
i wish the MD manual was clearer about all this.

updating on my optimistic comment, this actually sucks. it works for some tracks, but does not for others, and I can’t find out the reason. (i’m using it with a Kurzweil K2000RS)

even if it does work, this way of program change means that your first note in a pattern will be a sound you don’t want. and this renders the MD an ill-qualified midi sequencer. :frowning:

if there’s any idea how to make program change work properly, don’t hold it back.
…thinking of making a jump to AR?

You are trying to send program change to change patches on a synth while I’m using it to switch patterns on a Model:Cycles. I do it using the previous pattern and song mutes to control when to send the pchg before the part of the song when my Model:Cycles should switch patterns. It is quite tricky…

But maybe it would work the way you want if the pchg happens on the first track. That way a higher track’s note might be sent after the pchg … just a theory.

thanks. I prefer live sequencing over song mode, but have been thinking to go for it for my next gig, for the first time. never used song mode before. we’ll see.