MIDI Plays Free tracks won't play 'Direct'

I’m trying to mess around with Plays Free and I haven’t in a while but I’m having trouble getting it working on the MIDI tracks.

I’ve got them set up to play Direct (no quantize), Oneshot Track off, with ONE2 Trig Mode, I’ve tried all 3 settings for Start Silent and they seem to have no effect.

When I have that track selected, the first trig of the sequence lights up yellow just like it does in audio Plays Free tracks but unlike there, it never gets past the first trig. That first trig responds correctly to the trig mode (ONE, ONE2, HOLD) but no MIDI is transmitted.

When I select the tracks, chromatic mode works as expected. And when I switch Plays Free off, the sequences work perfectly.

The same settings are working just fine for audio Plays Free tracks.

Am I doing something wrong or did I find a bug?

1 Like

I just started a new project to test this and check whether something got messed up with the other one. This time I put trigs on the first steps of the Plays Free tracks. They actually play the first step of each but nothing else.

Same behavior as before with the light staying on the first step. It’s almost like they’re “infinitely slow” rather than stopped, if that makes sense (it doesn’t). Speaking of which, adjusting the playback speed of either track seems to make no difference. But they do respond to BPM changes, namely the note lengths change. Interestingly, the microtiming seems to be intact.

1 Like

direct is broken for midi tracks. can’t remember if 1 works, but anything above that should be ok.

1 Like

Oh, good to know. Cheers! I’ll give this a shot when I get home and if it works I’ll try to remember to hit the trig a little early :joy:

1 Like

6 posts were merged into an existing topic: Request to replicate this problem

Hi all,

Here’s something that has really been bugging me. If anyone could try these steps and tell me if they get the same result, or why it happens that would be great.

(It’s all related to the midi side of things, so have a midi device attached and start a new project)

Assign channels to MIDI T1 & T2. Can be the same channel or different, but as long as you have something connected to the midi out that will let you hear both tracks at the same time.

Go into grid recording mode and put some trigs down to play short notes on both tracks.

  • Make sue the two tracks will be easily distinguishable when played together
  • Make sure T2 has a trig on step 1, along with some later trigs
  • Exit grid recording mode

Go into pattern settings (Function+Bank) and make the following changes to T2

    Exit pattern settings

Run the sequencer and confirm all working as expected, ie. you can hear T1 looping, and T2 plays once whenever you hit the step 10 button (J / T2)

Go back into pattern settings and change SCALE MODE from NORMAL to PER TRACK

This is where things go wrong for me :disappointed:.

Hitting the step 9 button now only plays step 1 of T2 and gets stuck there

Does that happen for you? All responses appreciated

1 Like

Not sure about your exact problem, I’ll test it in a bit…

But I have encountered a very similar issue in the last few days. I’m not sure what triggers it but it happens just after I’ve saved and the sequencer freaks out, it will only advance to step 1 and just gets stuck there, seems to be on all tracks at once. even though the sequencer gets to step 1 there is no audio and I have to reboot to fix it. Luckily the issue is not saved with the project.

I’m thinking perhaps I am unknowingly triggering the issue you describe, or it is a related issue.

I just tested and it happens exactly the same for me.

1 Like

i suspect you need to make further changes to related settings… from the manual, see bold text:

TRIG QUANT is only available when the PLAYS FREE setting is activated. It allows both
quantized start and stop of the playback of the tracks. Note that the sequencer needs to be
playing for this setting to have any effect. The TRIG MODE setting, covered above, also
affects the how the [TRIG] keys will control the playback. Choose between the TRIG
QUANT settings with the LEVEL encoder.

• DIRECT will make a disconnected track start playing as soon as the corresponding
[TRIG] key initiating track playback is pressed.

• TR. LEN will quantize the start and stop of the disconnected track according to the
total length of the track.
• 1/16… will quantize the start and stop of the disconnected track according to set
step length. If the chosen value starts to blink that indicates the value, depending on
whether NORMAL or PER TRACK scale is active, exceeds either the length of the
pattern or the set master length. The track quantization will then will then be set
either according to the pattern length or the master length, again depending on
active scale mode.

Can also confirm, Happens to me too when following your steps.

1 Like

Thanks for checking, djenzyme & musicmajus! Looks like a bug. I’m on 1.25H. Maybe the problem crept in with this update - or are you guys on earlier OS?

Been over that section in the manual many times, invisible_acropolis. It doesn’t relate to the problem, as far as I can see, because I’m trying to use direct triggering, not quantized. (I’ve been using quantized triggering as a workaround, and there’s a problem there too - but that’s for another post!)

We would like to hear about the second problem.

I noticed that the triggering is not working correctly as well, it seems to trigger after 64 steps rather than the 128 that my pattern is set to. It’s fine though because you just have to press the relevant trig AFTER 64 steps have played but I don’t think it’s meant to work like that.

I just tested the 64 / 128 steps trigging thing. It works okay for me…

That is - if i set trig quant to 128/16 and I hit the trig during the first 64 steps, I don’t hear too soon - I hear it where you’d expect - at the beginning of the next full 128 step pattern.

There could be something different in your set-up that’s causing it maybe? I tested as per my example above but with T1 set to 64/16 and the master at 128, also tried with T1 at 64/16 but running at half speed, so that it took up the full 128 steps .

;My issue with trig quantise is similar though - just at the other end of the time scales 1/16 quant doesn’t seem to work as expected - but I have to check this more thoroughly - it’s probably me

OK, so in conclusion -

the thing that is broken is trigging MIDI tracks which are set to PLAYS FREE with trig quant set to DIRECT.


Yes I’m thinking something in my settings is affecting things, I’ve had a number of different issues in the last week or two, using 64 step 1/2 scale 128 master.

On the other hand, some things are clearly bugs that I am only just picking up on.

just noticing this - does this work with the latest OS? I’m still on 1.25D

It seems to work, but depends on the play mode and quantise settings, tricky to know what’s intended behaviour and what’s perhaps not working - a more frequent user who knows how it used to work may shed more light on this

did you get ‘direct’ to work? i thought too there might be a combo with which direct works. alas, i couldn’d find one.
everything else works just as expected…
(‘direct’ - as pointed out above - only plays the first 16th step and then stops right away)


There was this thread not so long back,


Also, I’m pretty sure I read in the manual that the MIDI tracks can only be triggered while the sequencer is running, the behaviour is different to the audio tracks. Maybe it wasn’t the manual but I read it somewhere