More issues with time stretching

I have a few drum samples that I’ve set the tempo in the attributes and time stretch turned on. In the settings, I’ve changed RATE to TSTR instead of PITCH. However, nothing is happening to the sample when I tweak the RATE knob. I can get the sample to reverse, but it stays at the same speed and never slows down. Anyone ever seen this? Is it a glitch?

1 Like

no one?

Perhaps accidental p-lock? Sometimes I do this by live recording


is it a chopped loop or individual hits? Have you tried just starting with a fresh project? Sometimes I get weird time stretching issues when im in 24 bit

all my samples are 16bit/44khz and it’s an individual sample. I can stretch other samples in the project, just not a few specific ones.

Do you have timestretch off in playback setup page? Auto reads from attributes, on or off overrides the attributes setting…

I have it set for on everywhere in the machine. I couldn’t have it more turned on if I bought it dinner while wearing a dashing suit.


Regular trigs, sample locks, slices ?

I will double check that it’s not in slice mode, but it doesn’t stretch when triggering with a slice note, track trig, keyboard, and actual placed trig on the sequencer.

Yeah I just checked, it doesn’t work in slice mode indeed. Didn’t know that.

Either way, I’m using a oneshot with slicemode off. This is ridiculous.

weird, maybe post the project and someone might be able to figure it out or replicate it? if it does turn out to be a bug now is a good time to report it, might be something easily fixable

Precision : It can work with slice mode on, length LEN set to slice. It doesn’t seem to work with LEN set to time.

Did you double check timestretch, set to Norm or Beat instead of AUTO ?

Hi, I just checked on my OT which is on OS 1.25H and I can confirm that my rate knob is working fine when rate is set in TSTR mode, no matter whether Slice is set to on or off. The LEN setting doesn’t matter here, either.

However, after reading the whole thread carefully (especially the fact that you can get the sample to reverse just fine) , my guess is that you’re expecting the ‘wrong’ kind of effect when rate is set to TSTR mode, which makes the rate knob functions very differently from when it is in PITCH mode. If you just one-shot trigger a longer sample and tweak it, the effect should be a lot more prominent.

Here’s a video that demos the TSTR mode very nicely

Hope this helps! And apologies in advance if my guess is totally wrong and I’m trying to explain something you knew all along already.

1 Like

I’ve had no problem lemme time stretching one shot drum samples in the past.

Do you happen to have a scene on setup to timestretch?

Nope. I’ve pretty much checked everything. I even tried switching the sample to a FLEX machine from the original STATIC machine. Still doesn’t stretch. It’s a mono 16bit/44khz snare sample recorded from an Analog Rytm.

Maybe your sample is too short ?
Does it work with a longer sample ?

@jaysomething is right, TSTR can work with LEN set to Time in Slice mode, but it doesn’t work with short slices, or when the slice length is shortened with Playback page LEN.

I made a test, trimming a snare : below 6143 sample chuncks (139 ms), it is not stretched.