My Digitakt seems to be going haywire!

Hi all!

I notice that my Digitakt stopped working with overbridge and via usb entirely… very frustrating. After upgrading to 1.30 to see if that helped, I now noticed that my Digitakt is going haywire in general - sending random crazy midi, seemingly altering random parameters very slightly in a random fashion. Argh!

Has anyone had their Digitakt go bannanas on them like this? It’s 3 years old (one month out of warranty :sob: ). I’m the only owner. No smoke, etc. Perfect condition otherwise. What on earth is happening?

I’ve logged a support ticket but i’m not holding my breath.

Have you tested the Digitakt (Func pressed at startup)?
Did a factory reset (save all you can before! And Func pressed at boot too)?
I wish you the best outcome.

1 Like

Yes - I have tried the test function but I haven’t factory tried a reset (my songs!) I have tried reflashing the OS however. I’ll see if I can save what I can and try a reset.

1 Like

Before you reset why don’t you unplug the Digitakt completely from all cables including power, flip the switch on and off a few times, plug power back in, and turn it on? No MIDI or computer connections.

1 Like

I downgraded to 1.20A and it appears to be working (at least - it’s not going haywire). USB still doesn’t work. I’ll try and go back up to 1.30 and see what happens

1 Like

It’d be more helpful if you gave any information about the DAW, OS, project, new songs, any additional kit, settings on Digitakt etc.

Without specifics or things you’ve tried it’s hard to tell what’s going on.

Fair enough.

Windows 10. Ableton. USB has recently stopped working entirely (windows says “port reset failure” in device manager). Overbridge therefore doesn’t work. The digitakt then started to go really weird - spitting out random midi, controls changing randoming. This fixed itself when I downgraded to 1.20 and then upgraded back to 1.30. Very strange.

So now my real issue is still the USB problem. No overbridge - no function what-so-ever from the USB port. I’ve tried it on a windows 10 PC and an OSX machine. No dice.

I’m not expecting anyone to be able to help really… I’m just venting. One month out of warranty and it starts acting strange. I’m not suggesting anything other than bad luck… but it’s frustrating.

1 Like

Now we’re getting somewhere! Do you have it plugged directly in or through passive/powered hub? Tried another cable?

Yeah, i’ve tried using the cable out of my Digitone (which is working) - same port. No luck. Tried directly, no luck. Different cable no luck. The weird thing is - my Digitone stops working when I try to use the takt at the same time now. Really odd.

Have you tried going into the settings on the DT and changing the MIDI function to 5 pin din only, and then back to USB? Maybe it will jog something into working properly again, sometimes things can get “stuck” as you’ve probably experienced. Have you unplugged it completely from power and all other cables, switched it on and off a few times to discharge, and then plugged it back in and turned it back on?

Checked with a loupe and light to ensure that the USB pins internal to the Takt aren’t bent, scorched, or somehow discolored?

Maybe some fluff that’s preventing a steady connection? Sure that happens more with my phone, but you never know…

Have you tried another USB cable?

1.30 is definitely far from stable, the LEDs on my Page and Track 13 keys are always the wrong colour, sometimes other keys. Sure is frustrating.

Reading through people’s issues makes me think I must be one of the chosen few for whom 1.30 was rock solid with no random light shows or demonic possession.


Same here, I’ve not had any issues with my unit :crossed_fingers:t3:


The only issue I had was with old projects. patterns with individual trigs using LFO’s locked to the tune parameter became something else(mod lfo 1, I think) when the second LFO was added, took me ages to work out what was going on