New Digitakt locks up when browsing samples

Hello all,

I just got a new Digitakt and there is a problem with selecting samples. Any time I go to sample selection the unit locks up completely and I have to restart it with the power switch. I recorded a short video to better illustrate the issue:

I have tried to run OS upgrade again - doesn’t help. I have also tried to reset the unit to factory settings - no change in behavior. Has anyone experienced anything like this? Does it look like a hardware issue?

Thank you!

So you’re connected to Overbridge at the time? do you get this problem when no usb cable is connected?

When usb cable is connected, check the USB Config. Do you have Overbridge ticked?

Screen looks green… I like.

Yes, it was using the Overbridge mode, but I just tried USB MIDI mode and without the USB cable connected and the issue is still there. When I try to upload samples using Transfer utility, I also get error that file could not be copied.

Sequencer is working just fine, I can run other gear from Digitakt… it really seems like the drive is gone.

I am also running v1.4 and just attempted your issue. It does not lock up for me when testing. What happens if you click left to the “View +Drive” menu? Can you demo the Factory samples?

I see sounds when I look at the sound pool or use Func+Data browser. They all look like they have their parameters in place, but none of them make any sound, because there are no samples. Also when I look at the sample waveform, it looks like there is nothing there.

as you say, seems like the +drive is goosed, not seen that problem posted here before. contact support, see what they say?

Yup, already opened a support ticket. I will post back when I know more. Thank you all :slight_smile:

1 Like

Small update. I formatted the +Drive and that resolved the problem with the lockups. I was able to browse sample library, but it was empty. Resetting to factory settings did not bring the samples back. Later an Elektron representative contacted me and confirmed that it looks like a manufacturing defect which was not fixable with any kind of software update. I am returning the unit and will get a new one, hopefully soon :slight_smile: