Ni maschine latency

Hi all,

I’m wondering if any other elektronauts have encountered the same issue i’m experiencing.

It is regarding latency incurred within NI Machine in standalone mode, while sequencing Overbridge enabled hardware (AR & A4) from Machine itself.

I have everything routed correctly.

That is to say, when i trigger a pad on machine, it triggers a pad on the AR, then in turn that audio is routed back to the same pad within Maschine, I have this configured for all pads and everything it running as expected when i only sequence my hardware.

The problem is when i load a kit from the Maschine library to another group, when sequencing that kit, there is a significant sync issue.

Even if i just enable the Maschine metronome, there are sync issues with my Elektron audio (sync offset doesn’t seem to adjust this.

I have experimented quite a bit with this in Ableton and do not experience these latency issues. I’m starting to think this is due to abletons delay compensation, which i can’t seem to find in Maschine.

I have all midi ports turned off within Machines preferences (to rely on Elektrons proprietary sync), and have all my buffer sizes matched (and as low as possible)

Anyone having this issue? or found a work around?

re Hi,

really interesting setup - why don’t you run Maschine in VST-mode and route audio in Live?

I don’t have a specific clue but it seems that you are adding ‘natural’ latencies of Maschine and OB.

Maybe there will be a chance concentrating on midi routing in adjusting the latencies on midi output.

Thanks for your quick response DiePie,

Actually that’s how I’ve been running my setup until now, with Live hosting Maschine and RYTM VST with no latency, or sync issues.

I’d love to sequence my Rytm directly from Maschine, unfortunately routing midi out of maschine when running it as a vst is extremely limited, although running it in standalone mode allows all the virtual ports created by overbridge to become available. Which is great! But as I mentioned, it’s not in sync with machines metronome.

I’m hoping it’s something simple I have missed.

Anyone in this boat with me?

So… I’ve found a temporary workaround for delaying tracks/groups within Maschine,

Its a Reaktor patch that that can be loaded onto a pad or a group, i’ve done some preliminary testing and now have things running in sync.

Unfortunately i have to load 2 instances of the device to a group layer to achieve a tight enough sync (approximately 40ms).

Additionally, this process must be repeated after auditioning and selecting additional kits for your project, which can be extremely tedious and not the intuitive workflow I’ve become accustomed to when using Maschine. It would be great if a device/function like this was built into the Maschine software itself.

I’m hoping someone has come across a more streamlined workaround?

Did you ever find a better solution for this?

Hi mate, the only solution I could find is to add a delay vst to all the groups you are running that don’t have your overbridge tracks in them. Slightly annoying I know but I did get a tight sync. I used the reaktor patch I posted, but you could use any delay vst that give you a non tempo synced option and deals with milliseconds. You would have to have it set to fully wet so you only hear the delayed sound. Hope this makes sense for you. I don’t think there will be an easy solution until NI implement delay compensation into the maschine software.

It would have been amazing to sequence my Elektron gear through maschine as I love it’s simple and quick workflow, but I gave up on this idea a while ago, the ball is in NI’s court now I guess.

Good luck with it mate.


I don’t have any problems sequencing both DT and AR from Maschine. I did have problems when DT was setup to also send midi to Maschine. Basically I have AR and DT set to receive midi only. Also at the moment AR is set as the audio interface.

Hi guys ! did you have an idea how to sequence machine from some hardware without having latency in reception of the sound in the A4/AR/ OT usb or other inputs ?

I have some ms of delay, machine kits are retarded so its really anoying :frowning:

Using Maschine in stand alone mode you have the ability to offset the midi clock to accomodate for latency, have you tried that? Also, is Maschine the master or a slave?