Noob MIDI Question Ableton


Something in Ableton I can’t get my head around.

When I have a couple of tracks and each has a vst in it
With configure and midi-assign I assign 8 parameters to the 8 encoders on my mpk mini
Now I would expect that if I turn an encoder, only the encoder of my armed track would change in value.
But instead, all values attached to that specific encoder change on all the vst’s, not only on the armed track. That has been boggling my mind for a long time.

Appreciate any help.

hi, sounds like the midi channels on the tracks are the same. have you configured the mpk mini as a normal midi device or a control surface? (if control sourface is not possible, that might be your problem) can you switch midi channels on the device? you could map different midi channels to the tracks and switch them via hardware…

1 Like

In Ableton Live it is possible to set a MIDI track to respond only to a specific device and or a specific MIDI channel. The default setting is for the MIDI track to respond to all MIDI channels and al devices.

If you want only armed tracks to respond to incoming MIDI ensure that on the unarmed tracks you have set Monitor to either auto or off.


Thx guys,

It’s really bizarre, but nothing seems to work.

I have switched all other channels to off or auto: no result
I have (de)selected the control surface in preferences: no result
I have changed the midi channels pretty randomly in Ableton: no result

Twisting an encoder is still changing all the values linked to that encoder in all tracks, not just the armed one. Could it be that the MPK Mini has some kind of auto-channel, just like the Elektron boxes? It is so strange that changing a lot of midi settings in Ableton doesn’t affect its behaviour.

I’m on Mac Mojave and I can’t get the MPK Mini editor to work, so I am not able to adjust anything on the MPK-side of things.

You don’t need to midi-map anything. As long as you’ve set the Control Surface (in Prefs) to MPK mini, you’ll be able to control whichever device is selected (you’ll see a blue hand on the device’s header)

Cheers. The problem is: if I highlight the VST in track 1 (which has a blue hand on the titlebar of the device), the VST in track 2 also seems to have a blue hand, because it is reacting to the same knob twist as the armed and highlighted track I am looking at.

And do you mean that control surfaces automap? Because how does the control surface-thingy know that I want the filter cutoff on encoder 1, Res on 2 etc?

yes, the control surface is for automapping.
to control 8 specific params of your vst, use ‘configure’ to add them, then group the vst device into a rack and map each param to the rack’s macro. then you can save the rack to your library to use any time.

but before you try that, remove those mappings!

here’s a quick example…



The above is an excellent explainer, works like a charm.

However: the fundamental problem that a twist of a knob on my MPK keeps affecting all tracks (and not just the armed one) persists. So still looking for the golden bullet.

If you are talking about something you have set up using MIDI Map Mode, then if you have used the same CC number to control parameters on different tracks then yes all set parameters will respond to that CC input irrespective if the track is armed or not.

Possible solutions are to use a different CC number for each parameter or use the same CC number but transmitted on different MIDI channels.

The MIDI mappings page will show you where you have assigned the same CC number on the same MIDI channel to multiple destinations

That must be it, thx. I figured out how to change the cc’s on the mpk mini by switching between program 1-4 (each program state has other cc’s on the encoders)

But does that mean you can’t assign a cc-number twice in a daw because you then are always affecting two parameters when you are turning a knob?

Don’t forget that there are times when you might want to change a number of parameters when you turn a single encoder.

If you want your encoder to only alter a parameter on an armed track the way to do this is not to use MIDI Map Mode but instead use MIDI learn (if available) on the VST you are controlling (right clicking a control knob in the VST’s GUI is the general way to access MIDI learn).

1 Like