NRPN messages are divided by 2

So this is really strange, and I thought it was possibly user error/weirdness with a new sequencer, but: I’ve just tried controlling Analog Heat using NRPN for the first time, and a full sweep of values will only reach the mid point of parameters - eg. max NRPN value for NRPN 0:74 (filter frequency) leaves the filter half closed. The only thing I could find on the board was an aside in this thread VST (without overbridge).

The reason for the post is part bug report (I created a support ticket for this on June 9th - but no response as of yet). I was wondering if anyone else ran into this annoying issue with the Heat receiving NRPN data. I’ve confirmed that the Heat is dividing all data values by 2.

Is this a known issue? Is it possible I’ve configured something wrong? For what it’s worth CC MSB/LSB works, so I’ve set up my sequencer to send that instead, but this seems like a fairly monumental bug if it is one…

1 Like

I just tried and i see this behaviour too - seems like a bug, it sends the correct data, but the same data sent back is not being processed properly

1 Like

As an aside, division in binary is just chopping off the least significant (rightmost) bit. Doubling a number is only a matter of adding a 0 in the rightmost position and shifting everything to the left.

The fix is likely a one-line change for Elektron, possibly even a single character change. The (likely) issue leading to this problem is so common that there is a term for it: fencepost error.

Powers of two (2, 4, 8, 16, 32, 64, 128, 256, 512, 1024, 2048, 4098, 8192, …) are common in electronic music devices both because doubling and halving is a matter of shifting left and right and because digital devices tend to be designed to handle 8, 16, 32 or 64 bits at a time.

Yeah, encountered it many times (and probably responsible for a few myself :stuck_out_tongue:) in my day job. I guess I meant “monumental” in the sense that the MIDI implementation just being…broken (possibly for the lifetime of the device) on professionally manufactured music gear is kinda nuts. But hey, I’ve had it for ages and only just decided to try and send it NRPN, maybe it’s just a device that most people don’t use that way. I’m glad I’m not going crazy at least, spent way too long today trying to troubleshoot it.


Hopefully it is an easy enough fix that they can validate and make the fix quickly before the next release. Seems like a high payoff bug - likely easy to test, easy to fix and brings the Heat into full MIDI compatibility.

1 Like

Yeah, just submitted a support ticket so will see what happens.