Octatrack / per track

hello guys… im using my octatrack on the per track’’ mode and i set some of the tracks on the 64/64 scale thing. but sequencer dont run till the last page, when it finishes the first page it goes back to the beginning of the page . has anyone experienced that?? any tips on what im doing wrong.

Whats the Master setting at?




got it !!! thanks a bunch !!! <3


Yeah it’s kind of weird that when you switch ‘per tracks’ on the master goes to 16 even if you had your tracks at 64 beforehand


Ugh this is even worse now. When you switch to ‘per track’ every track goes down to 16 steps so you have to laboriously go through them all bringing them back up to whatever length they were before, not forgetting the master scale (which was always a problem).

Think this further bugginess came in with 1.30-…

1 Like

Ok, necrothread dig here.

I haven’t noticed this issue before but as @Clancy mentioned above; when you switch to ‘per track’ and the Master Scale defaults to 16 which forces all the tracks to 16. Now this wouldn’t be terrible IF it maintained all your trig data from previously existing pages. So currently, when I expand my previously existing 64 step patterns, it just copies in the first 16 thereby losing those original trigs.

Is there a way around this??? I reloaded my project over and over trying to work this out.


I was sure it would… :thinking:

Just switched off my OT, so can’t test right now, but just in case set track and master lengths before you place the first trig.

It doesn’t save the pre-existing trigs which is crazy. The master Scale Length could at least default to 64 as an easy work around.

And yes, setting it before you place your first trig works but that doesn’t help once you’ve already worked on 6 of the 7 tracks and you decide you need your 7th and final track to be a different length. Definitely not great for a creative workflow. Terrible even. Gah!

I might try one other idea and report back if it works.

Unless you just get in the habit of using scale per track all the time on everything as standard. Do that first before doing anything else.


Yes, looks like I’ll have to. Would be good if this was the default starting point as opposed to the current way due to this issue.

1 Like

Any chance that copying the patterns to a new bank before turning on per track and copying back over works?

I tried that unfortunately and no luck. When you copy Patterns, that includes the time signature etc also. I also tried copying just the trigs but I couldn’t get that to copy as I thought it would but it’d keep the correct Scale setting. I ended up recreating the original from that, going back and forth between patterns and ABing them until correct.

I’ll try some more experiments with copy/pasting trigs to see if I can get some predictable results so we’ll have at least some sort of workaround albeit an ugly one.

1 Like

I really thought it did keep them…

I guess it’s possible that every time I’ve wanted to make the switch to per track my tracks were all made of repeats of page one anyway…

Share your firmware version and I’m sure we’ll get it decided either way

Definitely not keeping the trig data on mine. :frowning:

Would love someone to prove me otherwise. Maybe if someone can confirm they have the same issue? I’m surprised I hadn’t come across it earlier myself. I guess a lot of the time, I do change up all the Scale settings early on or like you said, have had a one bar pattern that wasn’t effected when truncated.

I’m on the final 1.4A firmware on the Mk2 Anniversary unit.

Yeah, just get in the habit of setting up your scale per track before you start playing. Takes a lot of practice. I do it intuitively now. Let the OT do things the way it wants to do and your experience will be much more enjoyable. Don’t fight the force Luke

Keeping data on mine. (OS 1.40A, MKI). I’d be surprised MKIIs behave differently (only bugs related to button combinations afaik).

On a 64 steps pattern I set trigs on track 1, with visual differences per page.

Scale Per Track > Change Track 1 back to 64 steps, placed as before.

@rdomain would you make a video, or list necessary steps to reproduce your issue ?

This is a option in PERSONALIZE menu : DIS(able) PAGE AUTOCOPY.
I tested with and without this option.


When copying a pattern I like to a new bank, I find often times it doesn’t sound correct until I also copy and paste the Part from the previous Bank.

1 Like

As far as I recall, the ‘lost’ triggers were always reverted when switching to ‘per track’. I wouldn’t cope with it.

I think this has nothing to do with the issue described in this topic. That said, I agree that weirdness happens if the part is not explicit copied.