Octatrack Update Error

Aloha Elektronauts :slight_smile:

I recently downloaded the new update for the OT Ver. 1.25D. I connected the OT to my laptop, turned on USB mode on the OT, put in the .bin file into the root folder of the flash card, deleted the old firware .bin file and went on to update the firmware on the OT (in that order respectively).

However, it was taking ages to load so I switched off the OT and tried to turn it back on but I would get some weird glitched message on the bottom right corner of the display and a 'D" on the bottom left corner with the Elektron symbol in the middle (see pic). It wouldn’t progress further. It’s just stuck on this screen.

This is the second time my OT has given me update issues…

Any idea on what might be the problem?
Should I have kept the old firmware file and waited for the update before deleting it?
How do I do a factory reset or restore?

Any help would be appreciated…


I’m sory to hear that. I didn’t update my ot yet. I still want to wait for all the bugs to be fixed. Can you get in factory test setup? Holding function i think when it boots up…
Maybe from there you can get in…

Hope this helps.
I feel your pain…

Ithanks for your reply… :slight_smile:
I can get into the factory test menu but can’t get in through any of the selections…
I have no idea what to do… I would like to avoid sending it back in again but if I find no solution I’ll just have to…

It looks like some kind of trojan virus… haha

At no point in the instructions does it say to delete the old .bin file.

I agree. Is there anything I can do apart from sending it back to fix it?

I guess you could put the old OS back on the card and give that a shot. I doubt it will work, but it is worth a try if you haven’t yet.

i would format your CF card, put the latest OS on it using a cardreader, and see if that lets you update via factory test menu.

The thing is I can’t even go to the menu to format the card. I can get to the menu that you get to while holding Function and turning on but that’s about it… I can’t send midi upgrade, doesn’t perform reset etc. it just goes straight to the screen with the funny icons on the bottom right…

What about upgrading via MIDI?

I don’t have a midi upgrading device. Tm-1 right?

I would suggest you send it back. Sooner the better. I had mine on repair for some knobs, trigger and a fader. Bought on thomann.de and it took them 3weeks to send it back to Elektron for repair and then back to me… And it came back brand new. It might take less time to repair the software. Contact elektron costumer service and ask them what can you do. I hope this helps mate…

All you need is a cheap USB to MIDI adapter- they’re like $10 on Amazon.
And a computer of course.

Are you saying that you power-cycled the Octatrack whilst it was attempting to write the OS update?

Becauase if you did, there is a fair chance that you interrupted it, and thus it never finished obviously, and thus the Octatrack won’t startup / can’t load because of a corrupt / unsaved OS.

Location? Can any other peep help you physically?

What was the previous OS version? I may have a copy lying around…

  • Get the previous OS
  • Backup your card data
  • Backup your card data again to a different location
  • Put the old OS on the card
  • Perform a factory reset via [FUNCTION] + [POWER ON] and [STEP 3] (<< ???)
  • Try reinstalling the current OS version via [FUNCTION] + [POWER ON] and [STEP 4] (<< ???)
1 Like

Ok !

I just got back from the local Elektron supplier (Filter Musikk) here in Oslo.
He was nice enough to let me do a midi upgrade using an Audio 6 midi unit that he had in store.
I performed a midi upgrade on the OT and now it’s updated with the latest software and works fine.
I did however lose all the files on the flash card :frowning: but I have a backup so i’m cool with that :slight_smile:
It’s great because I don’t have to wait 1-2 months waiting for Elektron to fix it knowing they’re always busy and especially this time of the year.
Thanks for all the help guys… you’re awesome!
Looking forward to uploading some stuff soon…

1 Like

It’s always good to have a cheap usb to midi cable to avoid some trouble like that, you should get one for those rare cases and it will save you time and headache :+1:

Check this one: http://www.thomann.de/fr/thomann_midi_usb_1x1.htm

Hello, i have the same symptom .My screen looks like yours.I try to update and looks exactly the same.Try to reset with function and power but nothing!!!

same problem trying to update at 1.31, someone serious so kind as to pass the 1.25 to see if I make it work?
Thank you


OCTATRACK_DPS-1_OS1.25E.zip (1.1 MB)


I fixed it today (1.40) with this option:
please see USER MANUAL:
I conected
then start SYSEX LIBRARIAN (Scarlet) PLAY and… after 50 minutes - I fixed it.

1 Like