OT ignores RLEN setting, records 16 sec instead

My sequence is 32 steps long and I want to quantize recording length to 32 so that the recording will always start at the first step in the sequencer stop 32 steps later. Instead the recorder keeps filling the maximum length of 16 seconds. Anybody know why? I’ve made a video:

If you can’t read the settings they are:
Recording 1 Setup 1
RLEN: 32

Recording 1 Setup 2
FIN: 0
AB: 0
CD: 0

You are probably after power OFF and ON again now, did it help?

Maybe save Part or Project and Reload it.

I’d also try with rec trig to check if it changes anything.

1 Like

You don’t inadvertently have more than one record trig ?

An additional rec trig would restarts recording. Btw it would be interesting to use them to extend or stop recording !

@mrcarlzone Welcome. Weird. It behave as it is on MAX. Which OS?
Could you try with a one shot rec trig?

:thinking: It reminds me something…
Did you make a part change previously? (RLEN MAX for previous part).
(I had a problem with part change, different recording settings not taken in account).

What if you set RLEN again?

1 Like

Also check if you have scale per track.
Check this topic


Maybe this is a silly question but do you have dynamic recording turned on? IIRC 16 seconds is the amount of memory allocated to each recorder by default. It won’t go beyond that unless you turn on dynamic recording in the settings. I think that setting is saved per-project.

If the recording last 16 secs, for me it means that Dynamic Recording is off, and it records Reserve Recording length, as you mentioned.

Thanks for the welcome and all the replies. I don’t use record trigs, nor a one shot record trig. The unit is just a couple of weeks old with OS 1.31. I don’t use differentiated scale lengths. BUT, in my project I switch back and forward from different patterns which in turn are connected to different parts. The idea is that one pattern is a programmed drum loop which I then sample (with main) in to recording buffer 1, then I switch to a pattern which only triggers the playback of the audio I just recorded. I can then slice the recorded loop, reverse, resample again and so on. I tried to replicate the error just now, but now it works. I think it has to do with switching parts, but under some kind of circumstances that are not clear. I want to try to get the error again. I think what happens in the video is a bug, because whats shows on the screen (RLEN=32) isn’t what’s actually happening.

1 Like

It’s a bug I noticed. Pissed me off. In the previous part, it’s preferable to use the same RLEN settings.

If you set again RLEN settings, it should behave normally.


2 patterns having different part and different RLEN settings.
Switch between them to reproduce the bug.

I found the post in the OT bugs thread