OT MIDI Loopback problem with LFOs changing P-locks on active track

I’m using MIDI Loopback on the OT to sequence it from the MIDI sequencer. Having fun and success with that so far, but I’m running into one really frustrating situation:

The MIDI LFOs keep running even when the sequencer is stopped. So when I try to edit my MIDI trigs, the incoming LFO’ed CC messages get p-locked to the step I’m editing.

For example, here’s part of my setup:

  • MIDI Track 1:
    • Sending to MIDI Channel 1
    • LFO 1 -> CC2, sending out CC#25
  • Audio Track 1:
    • Listening to MIDI Channel 1
    • Flex machine playing a sample

The LFO sends out CC#25 to control the Volume parameter on Audio Track 1.

But, when I go to p-lock a trig on MIDI track 1, that LFO keeps changing the p-locked value of the Arp speed! Because that is also hard-mapped to CC#25.

When I hold down the trig button, I can see the Arp speed p-locked and rapidly changing value as the LFO keeps sending CC messages.

If I set the LFO to “One” mode, then at least I can wait until the LFO completes its cycle before I go to edit any of my trigs, but sometimes that takes a long time, or I forget, and bam, as soon as I press and hold a MIDI trig, the running LFO changes the Arp speed for that step.

The only thing I can think of is getting some piece of hardware to “mute” the MIDI stream at the push of a button or something, for when I’m editing my trigs. But I’m really hoping there’s some simpler solution that doesn’t need more hardware!


If midi T1 and audio T1 are on channel 1, the midi track shouldn’t receive midi.
Is your Auto Channel on channel 1?

No, my Auto Channel is Off. I think the problem is that, by definition, MIDI Track 1 is the Active Track when I’m trying to edit it :slight_smile: And that track is set to Channel 1. I think the only way around this would be to stop the LFOs?

MIDI T1 is receiving MIDI because it’s set to MIDI Channel 1, and I’m in record mode. So that’s by design of the OT… but it seems to make trig editing a nightmare if you’re using LFOs.

You can mute the midi track to plock without the lfo.

The midi track shouldn’t receive midi because it’s channel is shared with the audio track.
It’s a bug.

Ah, mute! Good call, thank you.

I wish they would make it so that a double-stop would kill the MIDI LFOs!

1 Like

I think I have a better solution :

Choose midi T1 on channel 1 and audio T5 on channel 1 (instead of audio T1).
Seems to work properly that way in the midi mode, not in the audio mode (it receives the continuous lfo normally).

The plock with external midi CC should be an option.

I think that’s working. It seems like what the general bug is, is:

When an Audio Track receives MIDI CC messages, it automatically routes those CC messages to the corresponding MIDI Track for recording, regardless of channel!

I need to investigate further, but the problem is even happening when Audio T1 is set to MIDI Channel 9, and MIDI T1 is set to MIDI Channel 1. My MOTU MIDI Interface is remapping Channel 1 messages to go back out to Channel 9 in this situation. And still: I get the Arp p-locking problem I had before. Super weird.

This workaround will work for now, but of course as I start using LFOs on all my MIDI tracks (as I intend to do), I think the problem will be unavoidable.

I usually use Hold lfo setting, that way no sent lfo after stop.

Yes I think that’s it. We mentioned it here.

I’m using the Arp to send a bunch of notes with a single trig, then using the LFO to change sample start. If I use Hold in this situation, every MIDI note from the same trig will have the same sample start.

You can retrigger the lfo with trigless trigs.

Yeah but I’m using Arp speeds of x1 and x2… so much faster than additional trigs can help me with :slight_smile:

1 Like

You’re going too fast! :smile:
I tried trigless with trig counts, it doesn’t seem to retrigger the lfo.

I figured this is what you were doing with your amen break demo! :slight_smile: But maybe not.

The approach with the MIDI sequencer and the arp seems really nice because you can generate a huge amount of “full” trigs to play the audio side… which means it will re-trigger the audio LFOs, the filter envelope, etc. So you can do some really cool granular synthesis-sounding stuff where you’re pitch shift each individual grain with the arp, doing filter envelopes over every grain… it sounds amazing! But in that case I have to use the LFO in a non-hold mode in order to modulate the sample start time, or panning, or whatever else I want at the individual trig/grain level. I’d be happy to do it some other way, but I can’t figure out another way that can do all that.

The trigs on the audio side have always frustrated me because using retrig or trig counts doesn’t seem to do a “full” retrig (the LFOs and the envelopes aren’t retriggered). So it seems like MIDI is the only way to go. But I’d love to be wrong.

1 Like

The real fix to this of course is just to have 2 octatracks, each sequencing the other! :smiley:

I used trig counts on the amen break. Really interesting too if you don’t want midi loopback.