Overbridge/MIDI Ableton Sync Issues?

New Digitakt owner here!

First piece of hardware so still have a lot of learning to do, but encountered an Ableton integration issue.

Basically, trying to use MIDI channels 8-16 to control synths/drum sounds inside ableton. Digitakt is USB-connected and plugged into Ableton via Overbridge VST, with each MIDI channel routed to a separate track in ableton. They seem to be getting along in terms of clock sync, as evidenced by a sample channel recording in being perfectly on beat, but recording sequences in the MIDI channels leaves a big delay, as well as not entirely consistent spacing between each note either.

Anyone have any ideas?

Screenshots below:

Try selection Options -> Reduced Latency When Monitoring

Then set a negative Track Delay of -15ms

This is the closest I’ve gotten so far, thanks so much!

Still not 100% but a great bit closer!

Been reading more and more forum posts and various discussions; seems like perfectly in-sync MIDI from hardware>software or vice versa is something of a pipe dream and that all you can do is get as close as you can fiddling with different settings, is that the reality as opposed to what I was hoping for, which was just some switch somewhere in a settings menu I needed to flip?

Cool, glad it helped :slight_smile:

Have you set the audio buffer to 256? That’s recommended for Overbridge. Also, try slightly different Track Delay settings, maybe -16ms

You can also turn on Quantise in Ableton and then any MIDI you record will snap to the grid.

Are you sure you’ve fully quantised the track on the Digitakt before recording? Just checking :slight_smile:

Here are the latest preferences I have set up, let me know if anything sticks out as super wrong to you! the output buffer size is as low as I could get it without popping/clicking being introduced:


I don’t have quantize on on the digitakt, but I am recording sequenced notes here, I would think they’d be on-grid even without the q in that case, no?

And yeah I did realize at the end of the day I can just enable ableton’s record quantization if I really need it to be robotic and perfectly on-grid during recording, and to just decide if and when I want these little imperfections to be included. If that’s sort of where I need to leave things then I think I can learn to be ok with that!

Can I ask, what are you using the motu for?

speaker and headphone outs; I have 5 inch monitors on my desk that need xlr/quarter inch connections

I ask because it appears to have a huge amount of latency. To rule it out maybe you could try using the Digitakt as an audio input and output device, and set the sample buffer at 256ms and the Driver error compensation at zero. You should only get a few ms of latency. You can monitor everything (Ableton and Digitakt) directly from the Digitakt quarter inch outs or headphone socket.

I tried using the digitakt as the soundcard in ableton, and setting buffer to 256 did bring latency down to just 5ms, but the audio was garbled and unusable. I had to push back up to ~1200 samples for the crackles to go away totally, which left be back at latency of 25ms.

I’m using a decently powered gaming laptop, but it is a couple years old now, maybe the processor isn’t quite beefy enough to handle lower sample sizes?

Why is your motu sample rate at 48 and ableton at 44.1? Id put both at 48.

1 Like

Do you know which processor do you have?

Are you using a USB hub? If so, do you have any spare ports? You could try and connect Digitakt directly to your PC and not through a hub just to rule that out. If you’re not using the correct hub it will restrict your USB bandwidth for each device. Also, make sure you connect to a USB 2.0 or 3.0 port.

@BassesAndPads noticed that too, have since corrected.

PC Processor

I use a small USB 3.0 hub, but here are both latencies when bypassing the hub and connecting directly into the laptop, which are about the same as with the hub (mentioned 25ms earlier, found ASIO was better and it doesn’t choke out audio from other apps like I thought it did so doing that now) as well as my Processor specs.

1 Like