Potential Bug - MIDI Prg Change Whilst Playing?

I’ve found some strange A4 behaviour - maybe a bug.

I send MIDI Prg Changes from a laptop in order to switch kits (via switching patterns). If the A4 is playing, the Kit doesn’t change. If I do the pattern switch manually on the machine, it does.

This has caught me out a few times where the next song starts with the last song’s sounds. In some cases the oscillators are tuned up a semitone so sound totally out of tune when the synth kicks in. Very embarrassing.

Any thoughts on this anyone?



1 Like

It’s a well known behaviour of all Elektron boxes that programm change over MIDI starts with a new pattern. The only workaround is to send PC ahead.

How is this command generated and to which channel sended?

On your laptop you need to adress ‘ElektronAnalogFourMIDI’ on autochannel (14 by default) - not the plugin in a DAW’s track.

Check your MIDI mappings in setup menu if any remapping appears, i.e. pattern switching on incoming keys.

A workaround :
Pattern changes can be immediate with Multi Map, with Direct Jump and Direct Start settings.

My default auto channel is 9. :wink:

@TheDiePie & @sezare56

I’ve just done a bit more testing and it’s actually stranger than I first thought. I’ll explain more thoroughly:

What I’m doing is:

At the start of the set I hit play on the A4 and it starts a droney thing. A laptop running logic sits by my drummer. Whilst the drone happens we hit play on the laptop and play the first song of the set.

The function of the laptop is sending Prg Changes, firing off the lights, starting and stopping loop pedals etc. All to click.

I’m sending a program change to the auto channel (1) which is set to receive prg changes also. It’s coming in over DIN, I’m not using USB.

If the A4 sequencer is playing when Logic is stopped (by pressing spacebar) the A4 sequencer stops too (even though Receive Transport is unticked).

If the above conditions occur, the next time a Program Change is received (when we jump to the next Logic marker for song 2) the pattern changes, but the Kit does not.

I can change pattern manually on the A4 and the kit does change.

The problem persists until I press stop on the A4 (even though it isn’t playing) and then things return to normal.

As @sezare56 pointed out, autochannel is somwhere between 9 and 16. :slight_smile:

So you’re using a MIDI-USB-interface to serve the DIN-ports? Why not A4’s USB-port, it’s already there…?

I think it’s a matter of the (not using) autochannel, same as PC.

Did you save the pattern (with its specific kit)?

That’s because the pattern and its current kit still remains in RAM (if you did’nt save it before).

it does this when slaved to external MIDI clock… even with transport off, because when you stop the DAW, the clock has stopped as well… but there may be a way to have it send clock continuously, i dont know - however it may be possible to get around this by having the A4 use its internal MIDI clock, just set it to the same tempo… of course that wont work if you have tempo changes programmed in to your tracks

and yeh USB midi seems to be a bit quicker with response time, so Id use that if possible

with that said I have also noticed strange behavior getting the AK to work with DAWs when using some of the functions, cant really think of anything off the top of my head, but they appeared to be bugs and I didnt have the time to figure out exactly if thats what it was or not, so I just kept looking for workarounds and eventually got stuff done

and on that note you might want to try triggering patterns via MIDI notes with multi-map and see if the kit changes along with the pattern when you do it that way

Good spot, thanks.

It’s not useful for me to go into the details of this rig but it has to be DIN. The laptop is the other side of the stage also.

[quote=“TheDiePie, post:5, topic:43374”]
Did you save the pattern (with its specific kit)?
[/quote] I understand very well how the pattern/kit system works. It normally works fine, it’s just this edge case.

Mine is set to 1, and it has to be that for various reasons.

This doesn’t make a difference

Did you try with Kit Reload On Chg checked ?
Global > Seq Config > Kit Reload On Chg
Edit : won’t change your problem I think.

Did you try with Multi Map ?

I tried, slaved with Octatrack, sending clock/transport/PChange. Kits are changed when I change patterns.

Thanks. I haven’t tried multimap. I don’t know how that will change the rest of the system so i’ll look into that.

This might be specific to Logic triggering the bug, i don’t know