Problem with Overbridge recognizing my digitakt? HELP

Dear all,
Apologies if I am not posting this in the right place. I just got my first digitakt and have installed overbridge engine and with the latest software. I have an iMac running with Big Sur

Digitakt version is: 1.2A
Overbridge version: 2.0.47

I have read the manual and read on the Forums and tried everything suggested as people have had this problem frequently.

  • Overbridge Mode is On
  • disconnected device before installing
  • turned computer and device on and off before installation and after installation.
  • tried another USB cable, and tried connecting directly to the computer and not through the hub.

What am I missing here?

many thanks in advance

Public releases of Overbridge do not yet run on Big Sur:

Ah! thank you so much. that is what I missed!
I guess will have to wait until they find a solution , hopefully soon

Been waiting for months now. Hopefully this up date comes soon! Bought a new computer and haven’t been able to work with overbridge since :frowning:

I know! I fingers crossed. I shot Elektron support a message requesting the beta version. I have not heard back from them yet.

Have you heard anything? I’m in similar situation, and would like to join the overbridge beta

Hey there. Yes. I have. For the beta version they want people who have experience with software and previous beta versions assessment skills. I will still write back with interest in doing so. Though I have no experience, I am a researcher by vocarion, so o do have a a systematic way of approaching problems. Will see. But really not sure why don’t they release that version already.