Purchased Used M:S, Stuck on Bootstrap Upgrade

First time posting in a Forum so I apologize in advance…

I purchased a used Elektron Model Samples. When I got home I plugged in the power and the screen and it said " Bootstrap Upgrade Do no turn off". Waited an hour, went ahead and rebooted it. It then said Bootstrap Upgrade failed. It then went to the Upgrade screen and prompted me to press 4. I downloaded OS V1.13 from Elektron’s Website. I used the Elektron Transfer App V1.4 (I am on Windows 10) to send the OS from my PC using A M-Audio USB Uno adapter to the M:S, it received the file, but would never progress the screen. If I reboot it after receiving the OS it will either go back to the Bootstrap Upgrade Do not turn off screen or it will say Bootstrap Upgrade failed and will repeat the process of receiving the OS file. I assume the previous owner tried to upgrade it originally and interrupted the Bootstrap upgrade in which started this problem. How long should the Bootstrap Upgrade take? I was thinking of maybe trying an earlier version of the Model Samples OS but I can only find V1.13 If it only had some sort of status to indicate it is indeed upgrading it and just takes an eternity or that it is just froze on that screen.

Please Please if anyone has any information on what I can do to resolve this, I will be eternally grateful.

I’m a Model:Cycles user, but they’re similar enough maybe.
Does it function without trying to update? And if so, have you tried a factory reset before starting the update?

Thanks for the reply. When I turn it on it immediately will tell me The Bootstrap Upgrade failed the will revert to the Startup Update menu where you push the “4” to start the process or it will go straight into “Bootstrap Upgrade Do Not Turn Off” I have not been able to get it to any other functions. its only been those 2 options. I just recently purchased it used from an individual. My fault I didnt get to test it prior to purchase (not a smart move on my end) But I did get a really good deal, to good to pass up, in which now makes sense to me because of this issue. Im still not exactly confident in my own understand of a “Bootstrap” I figure it is similar to BIOS on a pc. Just seems like if there was a way to wipe it clean, reinstall the OS and if its not a Hardware defect it should proceed like a new device. Im just not sure if the Bootstrap is part of the OS that is being installed or is it flashed into the board from the manufacturer. just really seems to be a lack of information pertaining to this situation online with this brand. Very little from what I have found unfortunately. :frowning: Really bummed because it is a Birthday present to myself and havent got to play with it at all

Oh, I’m sorry :disappointed:
That’d be the extent of my troubleshooting knowledge here.
Maybe time to send it in for repair?

create a support account at Elektron and ask if it can be user recovered from the startup menu - or whether it is somehow ‘bricked’ - they’ll help either way - not sure if returning is required just yet

read the manual on startup menu and teh detailed install notes within teh text file of an OS - and be sure to have the very latest of both if doing via transfer etc