Recording into midi tracks

i’ve been at this for some time, and i have only succeeded in recording notes to the auto channel. I have found no combination of settings that will allow me to record to the active track, or the channel assigned to track one. I see hints of what might be wrong, but nothing that is explaining this symptom to me, though i do suspect it’s user error of some sort. I have only track one assigned to channel 1. cc direct connect is turned off. (the test is recording onto track 1, which is set to channel 1. the only way i’ve been able to record into it is to set the auto channel to 1)

i also keep on getting the msg ‘rec memory full’ though i’ve only recorded 16 steps.

i love the OT as a midi sequencer, and i’d love to have this working as expected. Thanks.

If message “rec memory full” then OT is recording audio to a recorder track.

Not midi to a midi track.

Make sure you have no recorder trigs on any recorder track.

Press midi button, select a track, choose a channel. Connect your external midi device from its out to OT midi in. Make sure external device is on the same midi channel.

Hit rec+play , do your thing. That should be it.

yeah. thanks. i’ve been doing midi for many years, and i’m not a beginner. there is some setting that is conflicting. i can record using channel one into track 1, but only if the auto channel is set to 1. i’m puzzled by the audio. i have no audio trigs of any kind set up. good god, am i going through octatrack hell? this is not easy. (yes - i’m an octatrack beginner, but basic midi routings - those are easy, theoretically). I suppose i can try deleting the project and starting again, but the major problem seems to be midi setup.

Start with a fresh project.
Remember, on the midi channel select page, you have to push the encoder to confirm the selection.

Take your time. You’ll get there.

(“Rec memory full” is a ram message, so somehow, the OT is recording audio somewhere. )

new project. channel of track one is set to 1 (yes confirmed it. and it’s set). can record into channel one but ONLY if the auto channel is set to 1. (yeah - i appreciate your help, and on the one hand am hoping that this is stupidity on my part, but i’ve been doing midi extensively since the early 90’s)

What channel is your external device set to?

i’ve tried 2 devices. both set to channel 1. and it is recording via auto channel set to channel 1. the external midi would seem to be correct. i think that it’s a setting within the octatrack.

Not at my OT right now.
Sounds like something is missing for sure.
Will have a look when I get home.

In case of any weirdness I bet on CC messages.

i appreciate it. i mean, it’s not urgent in that recording to the auto channel works…but i’d like to figure this out.

i doubt that it could possibly have anything to do with this, and i’m not sending any cc messages.

If an audio track midi channel is set to 1, you can’t receive midi data with a midi track set to channel 1 (except Auto Channel).


beautiful. i’m about to turn in for the night and have everything shut off, but that is obviously it (I think). Thank you!!

1 Like

yeah thats all I could find.
Go to settings, turn audio midi control all to OFF or INT.

Simple midi conflict. Easy to adjust.

I don’t think that MIDI / CONTROL settings are related to that kind of conflict. You have to use different channels in midi tracks, or change / disable audio tracks midi channels in MIDI / CHANNELS.

1 Like

I disagree.
Here’s my settings. Works totally fine.
I have samples on audio tracks, midi tracks controlling external synths, and incoming midi from a keyboard.
No issues at all.

@Microtribe, do you record on midi track 1, channel 1 with Auto Channel (11) set on your keyboard ? Normal if it works in that case. Using same channels doesn’t block midi tracks from sending midi, and they can receive Auto Channel whatever the settings are.

Maybe I misunderstood something, but apparently @Droolmaster0 wants to record with a channel different from Auto Channel (default being 11), hence channel 1 in his case. Doesn’t seem to work with your settings.

From what I just tested, and from what I understand from the manual, the only way to record incoming midi on midi tracks not using Auto Channel seems to use a channel different from channels used by audio tracks, whatever MIDI CONTROL settings are…

1 Like

yes. this was exactly it. did a quick test with a new project, and the only thing i did differently this time was changed the channel for the track 1 audio to 9. I left the default auto channel at 11, and midi recorded fine on channel one.

Thanks again.


Never forget that mantra:


I found it really helpful to understand that the channel blocking prevents MIDI loops when you “loop back” to use the MIDI tracks to control the audio tracks. Thanks @sezare56 for teaching me.

If it were me, I’d have written the mantra the other way around, so that the clauses read in the same order the MIDI signals reach the parts of the system:

If an audio track and a MIDI track share the same MIDI channel, the audio track will block the MIDI track from receiving data and the MIDI track will block the audio track from sending data

MIDI IN -> audio tracks -> |MIDI loop block| -> MIDI tracks -> MIDI OUT

1 Like