Roland AIRA System-1 sticks on update

Im trying to upgrade the firmware on my System 1, because I still have old version that has only 8 preset slots.

I want to expand to have 8 banks with 8 slots, and also the hidden waveforms as well!
But when I download the update and follow the instructions to update, it just stays stuck on the blinking part, and I leave it for hours and still nothing happens.

Tried at least 20 times now.
Anyone experience the same, or have any tricks to try?

Would really love to have 64 presets as opposed to just 8 :slight_smile:

IIRC the progress is shown by the scatter LEDs blinking, is that right? Is it progressing at all or staying stuck on the first LED?

Have you tried re-downloading the update file?

Also are you updating from 1.0 to 1.3? I have a copy of the 1.2 update if you want to try that one instead before updating to 1.3.

try factory reset and then udpate?
do you have most recent usb drivers on your pc/mac ?

i dont remember having any issues though it was a while ago.

Well…it worked now.

But Im not really sure what the issue was, because I did both a factory reset, and downloaded a new update 1.3 Instead of the 1.2 file I had from a couple months ago.

So it couldve either been a corrupt 1.2 file. Or the factory reset did the trick.
Anyways…works now!
thanks everyone


Be sure to check out the extra oscillator types they added too. The FM one is a lot of fun.