Roland RC 202 and softstep2 midi problems

Hello: new to the forum and new to this level of midi control
This is the only forum I could find discussing loopers. Any others?
I have a Roland rc 202 that I am attempting to control with the Kieth McMillan Softstep 2. I had it working using the rc 202 cc’s 80 81 82 83. Controlling play/record and stop functions for both channels. Here’s the rub. I had it working perfectly and it just quit. At the time I was using the Motu Micro Express to controlling other devices as well and thought maybe there was a tel- tale cc coming from somewhere else. So I disconnected the motu and ran the Softstep direct to the rc202 to troubleshoot. Nothing… I have tried every variation I can think of in programming the softstep, including duplictating the original settings that worked (for a while). I did a factory reset on the rc202, checked the midi and control setting bout 100x. The softstep is working fine as Ive tested it with other devices, I’ve switched cords… There is no perceivable communication. Any Ideas?
I am new at using midi this way and am probably missing something obvious. Thanx Much!!