Rytm mkii USB issues with Logic & Transfer [updated: possibly h/w]

As the title said.

After I upgraded my MacBook Pro (2015) to MacOS Mojave I’m having big issue’s with my Rytm.

I noticed it when I tried to transfer some samples, through Transfer.
Under DEVICE LIST it said “The device you’re trying to connect with doesn’t support Transfer.”

But sometimes it actually connect’s everything looks good for a couple of seconds but then it disconnects and back to square one.

I also have issues with MIDI Clock Sync from Logic.
It used to work like a charm and I had no problems triggering my Rytm to start when I pressed Play in Logic but since the update it’s not working as it should. After a second fresh install of MacOS Mojave it actually starts for 3-5 beats but then Pauses, when I continue to press Stop/Play it eventually starts playing (usually but not always, from the same place it stopped or 3-5 beats ahead) and plays for 3-5 beats again before it pauses again.

Logic gives a notification every two minutes about:
Changed number of MIDI Inputs/Outputs
Now 1 input and 1 output are available.

What’s going on? Elektron support did not seem to have a clue and says they’ve received no indication of problems with MacOS Mojave, but it works fine on my other MacBook Pro (2012) which has macOS Sierra.

Has my computer broke down? Everything else works perfectly fine, including midi over USB (though I haven’t got any sequencing hardware so it could of course be that but still I feel it’s still unlikely).

Anyone else had this problem?

What would you suggest?
I’ve checked all my settings on the Rytm (Input from USB / Output from USB / USB-MIDI Only and no Overbridge Mode) and tried find a solution / reason on my Mac as well but I’m out of clues and would really appreciate some serious help here :(. It’s important for me to be able to run my Rytm and have it synced up with my computer and able to transfer samples without hassle.

And please note I made another (!) clean install of MacOS Mojave and it’s acting the same.
I checked with other cables (usually use the red Elektron USB-cable that came with it) and it worked fine with the other computer and has worked fine just until I upgraded to Mojave.

Please help me out here :(.

Short description

Mojave messed up my sync between computer and Rytm. Looks like my MacBook Pro is dropping the connection over and over again but it could just be one of the symptoms of course.

I don’t think Transfer is Mojave compatible yet…there are other threads with the same Mojave issues.

That’s what I thought but when I contacted support they said that there weren’t any issues with it. They said they even run it themselves without issues.

So if some of us are having problems I think it’s a good idea to let them know, because they asked me to check these couple of things and said they didn’t have any more ideas since none of them had issues, and did not object when I said “so I’ll have to re install Mojave?” (= they’ve not even started working on a fix)…

Guess I’ll try to get a copy of Sierra and downgrade again, or will High Sierra function without issues you think?

High Sierra works fine here. Many audio programs aren’t fully Mojave compatible yet, and I believe most people wait a bit before upgrading to Apple’s latest macOS.


I got so tired of the Apple notifications and figured “I skipped high sierra and Mojave has been available to developers for over a half year and been out since fall”

So after checking 5 other developers software and seen that they had mojave support i decided it is probably alright, they should have gotten everything fully functioning

Elektron is saying they do have support for Mojave.
Which I feel is a bit odd if they don’t?

Question is, should I downgrade? Or stay on mojave waiting for Elektron (which software is the only one I’m having issues with)…

So incredibly frustrating, if it were 3 more applications messing out i’d be decided but now.

So how long will it take for them to realize there’s a problem and solve it? I guess for other developers 1 week to realize and 1 month to solve it.
For Elektron I guess 1-3 seeks to realize and 6- X month to solve… I paid €1 500 for this thinking Overbridge would be in place during the fall and and now it’s not even connecting with my computer :/. Which runs an operating system that’s been our for over three months.

I’ve talked with Apple support and they believe Elektron needs to fix this. But they made a note about it.

I’m currently downgrading to Sierra anyway.

Oh and they confirmed that it’s very unlikely to be a problem with my system due to the rytm worked fine until I upgraded and due to all other midi devices I have working.

They connected to my computer and checked it themselves.

I suppose they would, all I can add is that it works just fine on Mojave for me - so it may not be quite as black and white as you suggest

I’m not suggesting it to be black and white I just said what other said.

I’ve tried it out now downgraded both mac and analog rytm. problem persist so I was wrong to believe it was within Mojave.

It seems to be a problem within the rytm. I tried the cable for other gear and that works fine but I noticed that the cable doesn’t work unless it’s angled just the right way. It’s a defect. I had this problem once before before when I first bought the rytm. But I thought I had configured it wrong and that’s why the rytm acted all crazy. But it must be the USB-connection/port on the rytm that’s defect.

I’m waiting for Electron to reply, previously they’ve been very quick in their answers. I’m talking several responses a day but now they’ve been a lot more quieter, maybe due to people taking the last days of the week off due to Christmas holidays.

Anyway my Analog Rytm’s USB-port is a bit loose, is this the case with yours as well? The cable has never been possible to really connect into the device but is sticking out a few millimetres but that might be how the USB type B is.

But could someone just take a minutes and feel their USB-ports, mine is slightly moving when I touch is very gentle. that might be how it should be, but I’d like to know if that’s only mine or yours as well. I’m fairly sure that this issue is related to my Rytm’s USB-port now, I was able to get it to connect for a second here and there and when I gently moved the cable around.

the USB socket should probably sit flush to the surface of the AR chassis - but manufacturing/assembly tolerances may result in variation here, only Elektron will know the range of normal (sits flush here)

but a cable may appear to sit proud of it, even sit in loosely and be fine

but the socket shouldn’t be loose on the pcb - this sounds more like the plausible source of your issues given it was working out better before the time you coincidentally moved to Mojave

About the loose connector, it’s not loose loose but is not entirely still. It might not even be related to my issue. I never looked at it until now so I don’t know how it’s been but for some reason the connection does not work when the cable is not just right, which of course causes me problems and on a $1600 device i feel like it should work without issues like this (I don’t blame Elektron for a problem hat happens during manufacturing, it happens to all companies though they seemed to have a problem with the Rytm MKii in the beginning…) but I hope they’re willing to help. They seemed a bit “we can’t do anything” when I thought it was Mojave that was the problem but now it’s clear that it’s not the case and I hope they will be of more help.
Will let you know how things turn out! Still no answer on my ticket though.

Got a reply from the support yesterday that they will do their best to fix it as soon as possible and that they unfortunately have most of the closed shop for Christmas but will start working on it as soon as they’re back. So hoping to have it back and working soon :).

1 Like