Solved: Digitakt breaks other synths on stop/play (Microkorg XL)

Hi, I just got a Digitakt and have been trying to get everything set up. One of the synths I want to control from the Digitakt is a Microkorg XL.

It mostly works, but half of the time when I press stop or play on the Digitakt, it makes the Microkorg stop producing sound. It clicks when I trigger notes, but it seems to set an amp envelope to the shortest possible settings or something, and it doesn’t work again until I manually adjust settings or change patches.

Having my synth fall over every time I hit stop/play makes it nearly unusable. To make it actually function, I basically have to hit play then manually dial in the patch I want.

Not sure it’s Microkorg-specific. I initially saw similar behavior on an Atmegatron, but that cleared itself up and I’m not sure why.

Any idea what’s happening or how to fix it?

I’m using OS 1.08.

I thought maybe it could be related to using Linux to route MIDI over USB, but I tried with a direct MIDI cable with USB unplugged, and I get the same result. Maybe there’s at least a midi logger / debugger I could use to figure out what message it’s tripping over though, and perhaps a filtering program to remove it. Or perhaps after identifying it I could configure the Microkorg to ignore that message.

Okay, solved. A program called qmidiroute showed me what was happening. The Digitakt was setting CC 70-77 to 0 every time I pressed play, corresponding to generic sound control parameters 1-8 on the CC page. I initially resolved it by telling the Microkorg to ignore those CC messages, then later (because I’m a noob) figured out how to shut that off on the Digitakt. Shift and press knob for each of the 8 parameters on the FLT page.

The Microkorg maps those by default to a few envelope and oscillator settings, so the Digitakt’s default MIDI setup was basically telling it to mute itself.

At some point I should probably reconfigure it to take advantage of some of these features, but for now at least it’s not clobbering itself any more.


So digitakt sends out whatever assigned cc’s when I press play ?
Does it also send them out on pattern change as that might explain something I had a few days ago

I assumed they were only sent when I changed them / had trigs set

Hey folks

i have a pretty similar problem i think?
i had an old project where i sent CC messages to my external synth (virus ti) for some parameters. all working properly and used the setup with other synths as well.

but now i added a roland JV1080 to my setup and set up a new bank / patterns with just one midi channel (to begin slowly)
but there are still CC commands sent even tho i disabled all CC options via ‘‘function + CC channels (parameter knobs)’’
whenever i play a midi sequence on channel 1 there is a slight pitch modulation (as if the pitch wheel is controlled by an envelope curve or LFO) i cannot change that behavior. tried restarting everything, unplugging, creating a new project in digitakt.

but it won’t go away! :frowning: maybe you can help me out?
i don’t want to factory reset my gear :frowning:


I didn’t disable every CC message. It’s still sending mod wheel and pitch bend at least, because I left those enabled. However, I was having problems with those on another synth, where the Digitakt kept overriding the manual controls I set directly on the synth, and that was fixed by turning off mod wheel on the Digitakt for that channel. It was sending mod wheel events periodically even when the value didn’t change and there were no wheel events in the pattern.

It’d be nice if CC values weren’t sent when they didn’t change.