*Solved* Overbridge identifies analog Four as N/A, Ableton says wrong OS version

Until recently I had Analog Keys, and Overbridge worked perfectly with it. Today I traded my AK for Analog Four.

If I turn Overbridge mode off from A4 settings, everything works fine in USB midi mode. But as soon as I turn Overbridge mode on, problems start. Overbridge control panel only sometimes recognizes the A4 (but is very sluggish when it does) and sometimes recognizes it only as “N/A” type device. Windows says that “USB device not recognised” when Overbridge mode is activated.

In Ableton, if I try to add A4 device, I get error message “The paired device is connected, but runs wrong OS version! Please shut down your DAW and update your machine OS, then try again.”

What is going wrong here? Overbridge is latest (1.15), A4 has the latest (1.24) OS. I already tried reinstalling Overbridge and A4 OS multiple times, neither helps. I also tried factory reset, still the same issue. And as I said earlier, Analog Keys worked without issues using the same Windows 10 PC.

EDIT: Seems I managed to fix the issue. It was caused by Windows 10 “Anniversary update” which had installed couple of days ago - even though I have tried to defer it. The update had overwritten my audio, USB and several other drivers and that’s why nothing worked. After uninstalling the anniversary update and reinstalling all the drivers, Overbridge seems to work again. Awesome.