Stereo issues on flex recorder and thru

Anyone had this?

I was sampling through input A on T1 and had the recorder input set to A to get a mono sample (well a stereo sample with both channels the same). I would sometimes go to another bank to try out with the sample after I saved it. When I came back to bank 1 to do more sampling the recorder behaved as if it was set to ‘A B’ so the audio would be only in the left with silence on the right. Happened lots of times.

I had been monitoring the mono input via a thru track, also set to A naturally. Later I switched to stereo sampling through inputs A and B and set the recorder and the thru track accordingly (‘A B’) However the thru track still put out a mono sound (it was behaving as if either A, or A+B was the setting). I realised I could now just monitor via the mixer but wanted the thru to behave and found that it took several changes of input settings and double stopping the sequencer to get it to carry true stereo using ‘A B’

All this to say - my OT seems not to update input settings on either track recorders or thrus - perhaps after bank (and therefore also part) changes

Not really sure but my first guess is that since the thrus need to be trigged, they may not update the input source until stopped and retrigged… The thru will have a little play triangle when it is active, even when you press stop once, by pressing stop twice (or I believe track+stop), you will stop the thru, the track will show a stop square instead of a play triangle.
Try changing the input with the thru stopped and then trig the thru and see if it behaves…

1 Like

Yes - thanks - I’ve just been having another look at it and agreed think you’re right about the thru needing to be fully stopped to effect a change, but not sure under what circulmstances because usallu while a thru is trigged you can just change the input setting and the audio changes in real time.

The recorders definitely have a bug however: if you have just switched parts on another pattern, when you return to the pattern with the recorder trigs set up the recorder will have reverted to stereo

think that sums it up - can be reproduced on my OT anyway

Have you locked the input on the recorder trigs? The recorder trigs are stored per pattern but perhaps the default recording setup changes by part?

Well rec trigs can only be locked to pairs of inputs so the whole A vs A B thing doesnt come into it. In fact the problem persists without rec trigs - even just holding the AB button to record will record as if A B is set, though it shows A

1 Like

Hmmmm, I thought if you set in recording setup a mono input and then locked it in rec grid mode, that’s what it would lock, but I always use stereo so not sure…
Sometimes parts don’t fully kick in if you change to a new pattern/part when the sequencer is not running, reloading the part cures it, or switching while sequencer is going works…
That’s all from me for now, when I fire up my OT again I’ll check this out… Seems buggy but somehow I think there is an order to do things where it will work…

yes you can get it to work by double stopping I think (not with OT now) but this kind of setup should work as part of the live recording feature with no stops needed.

Thanks for the input though :slight_smile:


It actually fails to change to the part’s recorder settigs and inherits ALL the settings from the previous pattern’s part - including RLEN. So you can be looking at
A 7

but you can be getting


No time to check out the SETUP 2 screen stuff, but I expect that’ll be wrong too

1 Like

Sorry your in OT troublesville…
I’m still wondering if your switching patterns/parts while the sequencer is not running, because I’ve had similar things happen to me in this case.
I can say that I have a project that has different recorder setups on different parts/patterns, and when I change pattern/part while the sequencer is running they do indeed change…

It happens whether the sequencer is running or not. Just to reiterate - it is when you change the part on a pattern (sequencer running or not), then switch to a pattern with a different part.

1 Like

OK, i get ya now, I never switch parts on the same pattern(yet). I can’t think OT anymore right now or I’ll get a headache, but I will try to recreate this on my machine sometime soon and I’ll let you know… Good luck!

1 Like

Hi. Not sure to understand the issue,maybe I missed something, but :
I recorded A, nothing on B, got a mono signal.
I change to part 2, got back to part 1.
The behavior is still the same, it records only A.

What is your Os ? I’m on 1.25H.
Edit : I changed bank too. Seems ok when I go back to first pattern too.

1 Like

Hey thanks for taking the time to try it!

Please note that pattern changes come into this, so-

On pattern 1 verify ‘A’ setting works okay

Change to pattern 2 and change the part on pattern 2 let’s say to part 2 (where it will presumably be set to default A B)

Go back to pattern 1. The recorder will behave as if it was set to part 2 even though part 1 is assigned AND the setup screen displays A not A B

1 Like

Ok I reproduced the issue when I changed part 2 in pattern 2 when I went back to pattern 1.
It didn’t do it with bank change or when I went back to pattern 2, which was still with part 2.
I had to change pattern 2 to part 3 to do it again.
Unfortunately, you’re right. :tired_face:

1 Like

Thanks for confirming! Will report

1 Like

Thanks ! :wink:

1 Like

Nice work team… Another bug…

Thinking about workarounds for this I remember you can stop the thru track by pressing track+stop and the sequencer keeps going, trig it again with track+play.
Maybe a quick part reload after the pattern switch might cure the recorder trigs, although not ideal, just some thoughts…

1 Like