Stop OTs "soft thru" of midi notes?

I’m using a Motu Midi Express XT in “Live Keyboards” mode in my setup. So midi loops is a thing of the past. But there is one thing that is somewhat of an annoyance.

I use both an MPC1000 and my Octatrack to record midi. On the MPC there is the option to choose if the active track will send the midi information straight to the midi out. It’s called Enable/Disable “Active track soft thru”. I can’t find a similar function on the OT. So my question is if there even is this option?

The reason I need this is because of double triggering of modules in my rack. My master keyboard sends midi notes to the rack modules midi channel, which is good. But I need a way to record the midi notes to the OT, but without sending them to the rack module in realtime through the OT. Is there a way to turn of this “active track soft thru” behaviour of midi notes on the OT?

I hope I explained it well enough. Any thoughts would be appreciated.

I tried, I don’t think so.
It’s because you continue to play after recording a pattern?

You’d be disable the midi channel and record with the Auto Channel, and choose the right channel after, but won’t hear while playing, unless you send your keyboard directly with another connection.

Alright… Thanks for testing it.
What i’m trying to do is to play the rack modules directly from my master keyboard, but record the notes on the OT at the same time. But i don’t want the OT to play the recorded notes until the loops starts over and I stop playing the keyboard. I prepare the correct midi channels before recording the loops. So they are set up to start playing back the notes on the next 1 in a 64 step sequence. Basically a looper function but only with midi.
I achieve this as is, but this way all notes are sent twice to the rack module.
I could connect the master keyboard directly to the OT, but then I always need to turn on my OT. Even if I only want to do some sound design on my rack modules (my master keyboard has a sequencer, so I don’t need the OT for sequencing basic tasks).

Live condition with audience?
A midi switcher?
Disabling midi channel and press Yes to activate right channel when finished?

This is surely a good idea.

The alternative would be to program a different setup in your MIDI interface.


It’s of most annoyance during live streams currently.
Thank you for your suggestions. I just needed to know if there was a setting I was overseeing.
I have solved it by hooking my keyboard straight to my Mpc and OT for now. It’s not ideal but it works.

1 Like

The midi implementation in the OT incorporates a couple of design choices that can be quite annoying if you don’t need them. Especially when it’s about echoing incoming midi.


What bother’s me the most is the fact that similar concecutive CCs are not sent.

1 Like

What option in the settings do I need to have checked to enable a midi track by only pressing YES :thinking: ? Could be handy sometimes.

Elektron devices turn out to be quite egocentric (I’m a fairly new Elektron user). The developers didn’t take into account that one might want to use other controllers in conjunction with their own devices to control other devices…

I was talking about validating a midi channel change with Yes instead of button presses.
Otherwise : Track Mute! :slight_smile:

1 Like

Alright, thanks :v:

Reviving this thread to ask if anyone has found a better solution to this problem in the past year, or if any OS updates have improved the situation? I have all my elektron devices in a complete midi loop and the midi echoing on octatrack makes recording with an external keyboard impossible.

There have been no OS updates for the Octatrack since this topic was created.

Your setup sounds different to the OP’s. What is your setup and what is happening?

Well i feel a bit silly because after making this post I went back to my setup and figured out a solution. By using auto-channel to record into the OT, the notes that are “echoed” are on a different output channel than the channel they came in, and this solves my problem.


But it remains a PITA especially if you have devices on all channels in your setup!

1 Like

Adding a +1 to this suggestion as it’s a pain when combined with the Octa’s MIDI thru limitation if you use a lot of MIDI tracks.

An option to disable MIDI thru would be great or even an option to send thru on all channels (not just those assigned to MIDI tracks on the OT) so that it was more practical to send the controller directly into the OT for those of us who use more than 8 MIDI channels.