Suggestion on how to connect my elektrons to my laptop

Hook up both via USB. You need to use the Overbridge plugin to route each audio track from the units to the tracks in Ableton, you don’t do it through the audio device. So rather than create an audio track in Ableton and setting the audio input, you create a midi track with the Overbridge plugin, and set the track routing in the plugin. Then it’ll behave just like a VST synth on that track.

It works very well, Overbridge is really great.

Thanks for the answers. I never tried to use the daw as the master (digitakt is usually the master of my little set up). I should try that so to make it work . Thanks for the suggestions

Always use the daws clock as the master if you involve a computer in the equation


But can I keep using the digitakt as sequencer/muting master? In this case I think I have to keep the midi cable connected between the two machines.
The clock could be from the daw

Yes you can clock from your DAW but still sequence/mute from the DT to the DN. Keep the midi cable connected and you’re good to go. Just make sure clock send is turned off in the DT.


I had both my DT and DN working with Overbridge together and made an Ableton Live template so all tracks were set up and ready to go. Easily done, just plug both machines in via USB.

1 Like

Yesterday night I tried to connect both the DT and DN to the MacBook with usb.
So the general connection is : DT outs to DN ins; DT midi out to DN midi in and both the machines usb connected to the laptop with overbridge mode (usb) enabled.
Good news is that I can see both the DT and DN in logic and therefore I can break down all the tracks of both of them (as I originally asked in my thread).
Bad news is that there is a weird thing happening…I try to explain.
I am recording a song where in the track one of the DT there is a composite drum tracks with different drums elements (kick, snare and hh). When this track plays alone it is ok. When I unmute some DN tracks only the kick is audible and all the other drums components (snare and hh) disappear. When I mute the DN track the missing drums elements appear again…
Why that? What am I doing wrong?

It sounds like your DT’s drum track is receiving midi…you should disable it from receiving midi. I don’t use Logic, but in Ableton you can do this for the whole device. On the DT you can also do it in a per-track basis, so make sure you have all of you internal track midi channels set to “none”.

One common problem you can get is a midi loop back, where the DT sends midi into the DAW and then receives it back again. You just have to be super careful with your settings and routing.

Thanks. I am really newby in this world…
I did not understand exactly what you meant…

Is this the page I should turn everything to off?

1 Like

I understood the reasons of the problem above.
I have the first four midi tracks on the digitakt set to channels 1,2,3 and 4 respectively. These tracks control the digitone tracks.
Well…when the two machines work without daw everything is fine in this way.
In Logic there is the a.m. weird behavior because the daw sends back to the digitakt a midi message on the channels I trig. In the example above every time I activate the midi track number 1 (which is the first track on the digitone) it re triggered also the first digitakt audio track and in the way I listened only the kick and not the compete drum loop.
I solved it setting the midi tracks on channels 9,10,11 and 12 so that no audio tracks are triggered when these midi channels are activate.
Now a little other issues appear…
When I activate the second digitone track(midi channel 10) the pattern sequenced in the first digitone track keeps playing its part but it changes the sound using the one associated to the track n. 2.
Why that?
I think each track should keep playing with their own sounds and settings…

Do you have your Digitone autochannel also set to 10?

Yes. Might it be the reason?

I would guess so, yes. If you have set set Midi track B on the Digitakt to channel 10 in order to control track 2 on the Digitone, which is set to channel 10, but ALSO have your Digitone auto channel set to channel 10, then anything you try to sequence on the Digitakt’s midi track b is going to always affect both track 2 on the Digitone, but also whichever track is active on the Digitone. I would definitely read the manuals about how autochannel works.

With USB

Thanks a lot. I will read them again

It is always myself…
I send the software tracks of the digitakt and digitone to two separate buses in logic and then create two audio tracks for each buses so to be able to record.
However I would like to have all the single digitakt and digitone tracks splitter while in the am way I have them all together in the two audio files…
How can I do that? Thanks a lot

Your questions is kind of hard to be quite sure of, but if I understand you correctly: Create individual tracks for the DT tracks and DN tracks. Then group these, or send them to busses. You’ll then have control over the individual tracks, and a stereo channel for each.

But how can I create individual tracks from the digitakt and digitone? I can only have a track which is global (I.e. comprehensive of all the tracks aid each single machines)