Tempo gradually increases to 300bpm when sending CV sync

I’ve been running my A4mk1 directly connect to my laptop for a while but have reconnected it to my main setup and am having problems with clock speed increasing when it’s connected to CV sync out.

The A4’s running as a MIDI clock slave, receiving clock/transport from the Octatrack but sending a CV sync to the Keystep.

I don’t think I’ve changed any settings from when it was syncing ok on either the A4 or Keystep. Tempo locks in fine when the CV’s disconnected but when it’s connected to the Keystep the tempo starts to rapidly increase to the max of 300bpm as soon as I hit play.

Not sure if it’s a factor but I use Overbridge on USB for preset editing/audio recording (no sync or MIDI sent to/from PC to A4).

Any ideas what might be causing this?

Maybe a loop?
Does the KS send back midi clock while receveiving CV sync ?


I think this is the case. I remember having to use my MIDI Event Processor to filter clock/transport from going back to the A4/DN or whatever I had it connected to at the time. I don’t recall Arturia MIDI Control Center having a setting to disable that either.


Damn, yes that’ll be it. What’s changed since before is that the A4 is getting a MIDI thru and before it was just getting a MIDI out from the Octatrack (which won’t have passed the MIDI clock).

I think you’re right as well about the lack of clock option for the Keystep, v.annoying that modern gear with so many options doesn’t allow this.

I thought I’d just nailed my MIDI routing too as it’s getting complex now. Looks like it’s back to head scratching or buying yet another black box…

1 Like

Yeah, it’s a bit silly. I had my event processor laying around so it was easy to setup but it’s just another expense to solution for a problem that should be correctable in the KS config software.

To add to this, I think you can disable sending transport when receiving clock externally but the problem is when you hit ‘Play’ on the KS to start the arp or sequencer, it starts sending clock. Just no way to disable sending clock full stop.


Just bought another merge box to sort out the new setup and had that triumphant feeling of solving a long standing problem. Ah well, everything else is working so well I think I’ll just ditch the keystep sync for now.

Maybe some routing workarounds…

CV is for KS arp sync?
Is it plugged to OT ?
In that case, is OT Clock and Transport Receive disabled as it should be ?

Maybe A4 receive KS clock directly. It should be possible to filter KS clock if you plug it to OT before A4, and not connect it to A4. Send back KS from OT to A4 using a midi track, same channel as KS…

Yes, it’s for arp sync. The keystep has a beat synced arp which is the main thing I miss having on the Elektron boxes. OT clock/transport receive are disabled.

I’ve got a few input devices (AN1X, A300, HD500 for footswitches, Keystep) all connected to a merge.

Ideally I’d just connect the output of this to the OT in, but I use a lot of channels and find the thru restrictions of the OT really limiting (I tend to play a lot of stuff on the fly by switching channels on the AN1X/KS and using their arps).

The problem is that to solve this I’m then putting the merge-1 outputs into the OT IN and into another merge/splitter-2 that combines these input devices with the OT out, and then sends it to the chain of synths (including the A4) creating a loop with the KS/A4.

I guess a good compromise would be to take the A4 out of the main output chain and only send the direct OT out to it. Then I’d need to set an output channel for it on the A4 (a bit annoying to lose an OT MIDI channel as it’s the only synth I never sequence from the OT, but everything else would work ok).

Is the only option to do it this way and buy another splitter to send the OT out to the A4 & the input of merge-2 so that the A4 doesn’t receive the input chain directly?

(I guess I’m asking a lot to be able to control everything with everything like this, but this setup really works well for how I play, and apologies if the explanation causes any headaches, it’s given me a couple :slight_smile: )


Merge/splitter-2 also has non-merged outputs that let you pass through either input, so I’ve taken the A4 out of the chain and just feeding it the direct OT output now. Keystep syncing happily.

No problem using an OT MIDI channel if I want to sequence/play it externally, but that’s fine as I mostly use the A4’s own sequencer.

Many thanks for helping me get there :slight_smile:



Digitone arp is synced. Unfortunately its quantization is 1 step, what the arp speed is.

With OT I found a trick to sync arp with external keyboard playing : a toothpick on trig 1!
Per track scale = 2 steps.

This way you’re arp is synced…

1 Like

There’s always a way isn’t there? :slight_smile: They should include one with the A4, ‘Now with beat sync stick’.