Transfer not connecting / Checksum error (A4)

Yo! So I’ve not upgraded in a while and want to get the new OS on my machines. I downloaded the Transfer app (OSX Catalina). On the Connection page it’s seeing my A4 but when I press ‘Connect’ the spinning arrows spin but nothing happens.

On the LEGACY page I try to send the OS update to the device and get CHECKSUM ERROR on the A4 and it crashes. OK I’m on 1.23 from a while ago (alright I’m lazy! I know I know).

My main priority is backing up. I did some backups a while ago so most stuff is safe. How the heck am I supposed to backup to this Transfer app?!?!? Is there another way THAT WORKS? Yeah I’m looking at YOU Elektron

Thanks in advance to anyone who’s able to help :slight_smile:

Also WTF is a checksum error. I wish tech companies would use everyday language on their devices, normal people like me don’t know that that even means

Shortest explanation: the update, as received by the hardware, was corrupted. Which might mean the original file was corrupted, or it might mean the file was good, but something went wrong sending the file to the hardware.

So you could just retry, both retry the update to the hardware, and retry the download of the file.

Thanks for the input. I downloaded the file again and changed the USB cable but sill getting the same error “checksum error”. How annoying.

Can anybody recommend another way of doing this without using this Transfer app? I used to use the C6 app and it worked fine

Given that you’re combining a new Mac OS, with therefore presumably a very new version of transfer, against what sounds like an old version of the firmware … maybe this is a bit of a special case, and worth filing a support ticket (presumably on ) ?

Caveat: I’m new to the whole Elektron thing, but I’m thinking about this as a developer.

1 Like

Sysex librarian. Havent tried it yet, seems to work for some people here. ( search this forum and/or your search engine) Also I mention beware of data and saving structure on a4 ( soundbanks and projects seperate). But you said it worked with c6.
Or visit a friend who has windows or mojave with a usb stick and a bottle of wine.
Good luck have a nice evening

Edit: librarian, not liberarian

And thats for backup, transfer should work for os update in catalina.
Edit : seems maybe not, someone was given advice to use librarian for catalina os upgrade too, when he had a checksum error on model sample.

1 Like

Cheers guys, great advice. I figure it’s because I haven’t upgraded in ages and stuck on an old OS. Serves me right for not keeping everything up to date but oops sorry I have a LIFE! Only joking of course.

Gonna try Sysex librarian. Also I have an old dual boot MacBook running High Sierra so will try that too. Failing everything gonna open a ticket.

Thanks again!! Much love

Hello, me again. I got my A4 updated with the latest OS using SysEx Librarian, so now I can see it ok in Transfer, but how the heck do I backup my projects to the Transfer app? Sysex dump does nothing - what am I missing here? How to people backup these days since C6 has disappeared?

a recent answer to that is already in your thread 2 posts above

1 Like

No joy there I’m afraid, but thanks for the input. sysex librarian is seeing the A4, and it’s set to USB mode. When I hit record and do a sysex dump, nothing happens

I made a more detailed post here too, not wanting to spam the forum of course

Woo I found C6!

Gonna give that a try on an old MacBook I have running high Sierra. Fingers crossed.

Not today though as my brain is fried

probably best reading the existing posts rather than ‘spamming’ more identical questions :zonked:

backups work fine for me, so it’s hard to tell what the issue is

search older threads on setting sysex librarian up

specifically …

1 Like

Thanks for that - yeah I don’t want to spam obviously but it’s ridiculously frustrating knowing the functionality of C6 has been removed in Transfer