Trigless trigs trigging amp?

This has been driving me insane tonight.

I want to do something simple like change the tuning of OSC 1 during a held note without re-trigging the amp/filter/env2 envelopes. So I figure the proper way to do this is to p-lock a trigless trig with the change.

The problem is that it never works reliably, and the behaviour appears to be random. Occasionally the trigless trig will re-trig the note envelop (amp), sometimes it does not, and sometimes it simply stutters slightly irrespective of the amp settings. It doesn’t matter if there’s a p-lock present or not. The type of amp envelope doesn’t seem to matter (dotted or not).

I’ve tried various things, and it seems completely random. Sometimes it works correctly with a blank pattern, sometimes it doesn’t work correctly at all.

I am currently clocked as slave to an Octatrack. I don’t have the ability to undo this atm as it’s racked up, but take that into account when trying to reproduce the issue.

Any ideas?

I’m trying to figure out a reliably way to make this happen, and I’m failing :frowning:

works reliably here, no octatrack connected tho

  1. grid mode
  2. trig a note, hold trig, extend it (len in Note menu)
  3. Fn+trig a trigless trig(s), hold trigless trig, change pitch (note in Note menu or Tune in OSC menu as you stipulated)

note: make sure the original held note has a suitable envelope which sustains the note for as long as you want first (also check EnvF) + ensure that the trigless trigs do not have either envs retriggering, that is default (Encoder F Encoder G in Note menu)

Thanks for testing it there.
I woke up this morning fresh and ready to try it again. Everything is still working oddly here.

Before I stopped messing with it yesterday I was able to make the ‘bug’ happen on a blank pattern with one trig and no changes to the default sound/pattern otherwise. It really seems random at this point.

I’ll put some more serious effort into figuring out a reliable way to reproduce it. Pen and paper and logging everything I touch.

So I’ve worked on this some more and I’ve found one way to reproduce it.

If you set a trigger and then hit [fn-trig] on the trig immediately after it plays, it make it a triggless trig and SOMETIMES it will also p-lock the note parameter. This causes the trigless trig to re-trigger the amp.

The main thread I’ve noticed between the above method and it occurring by simply hitting [fn-trig] on a blank trig is that when it goes wrong, the note parameter always is getting p-locked somehow.

Still working on figuring out why it’s happening without using the method of converting a trig to a trigless. It happens, I just haven’t found any logical reason yet.

So if you’re interested in figuring out this bug as well, look out for trigless trigs locking the note parameter.