Use external midi keyboard to play OT

I’ve been wondering if I could use my AKAI MPK25 to play some OT track.
Advantage: MPK has 2 octaves and velocity.

I’m aware of the step by step MIDI in approach, but that’s not what I want.

I couldn’t find anything in the manual.

Thanks for your suggestions

The 2 octaves may lead to some restrictions in regard to what you would like to control and what you will actually be able to control (simultaneously):

See MIDI Control Reference section in the back of the manual.

Different note# in different octaves trigger different functions. Depending on what you´re after, there may be some situations where your MPK25 limits you. You are most probably able to use transpose/octave selection in your MPK25, but it might become inconvenient if you would want to use two functions that lies in two different octaves…

With that said, I don´t know how much you are able to actually program in your MPK25. Perhaps, it´s possible to make some nifty workaround settings specific for your OT?

1 Like

Thanks for your response, Mike. I am aware of these key assignments.

I just thought something as trivial as an external keyboard playing back the sample(s) loaded into a track at different pitch and velocity should be easy to achieve?

Well, there IS an Chromatic mode of course (see page 82).

But I´m not sure if it´s possible to get there with external MIDI keyboard instead of using the trig keys. I´ve never tried and a quick glance in the manual doesn´t reveal anything (might be looking at the wrong pages though). Maybe this is what is mentioned in the MIDI reference section:

#7 Chromatic Trig Channel n, octave 1
#8 Chromatic Trig Channel n, octave 2
#9 Chromatic Trig Channel n, octave 3

To be honest, I don´t understand these three above (yet)…

If it IS possible, I´d be very surprised (but happy) if velocity where controlling the volume of it as well…

there’s no way to program ‘velocity’ per sample, so i guess it’s not possible to record it anyway - there’s no documented relationship between velocity and e.g volume for sample playback - the only way to record playing dynamics is via midi for the midi tracks - the chromatic mode is a nice to have, but quite why you don’t toggle octaves using the scale button is beyond me as a UI choice, it’s not that obvious that it’s actually set up as an E - far more useful if it flicked between upper and lower octave

[edit] mike typed whilst i was trying out and typing !

externally, yes - it responds to the two ‘complete’ octaves the sampler can play - ie 2 octaves C>C either way from reference C - the midi range used to control playback is academic it is 72>96 but the equivalent standard pitch is meaningless

you can play the 2 octave chromatic range over MIDI. sadly velocity and aftertouch can’t be assigned to mod anything on the audio tracks, and you can’t trigger slices with MIDI notes (one of the most common feature requests). you can setup your MPK knobs to control all of the usual lockable parameters.

just pay attention to which octave you’re sending the notes in, as notes in lower octaves can start and stop the sequencer, among other things. see appendix c in the manual, as mike suggested.

Is it possible to do this?

I connected a keyboard to the OT’s midi in, I put the OT in Chromatic mode but I would like to use an external keyboard to trigger the notes instead of the OT’s keyboard.


The OT doesn’t have to be in chromatic mode for that. If you match your keyboard’s output channel to the auto channel on the OT you’ll be able to play your current track’s default sample +/- 1 octave. You just have to find which two octaves on your keyboard will do that. Check the midi charts in back of OT manual for the note numbers.


You’re lucky, I just maid a summary of Appendice C Note Mapping, with a few precisions : :wink:

Edit : something better here now :

C1 - G#1 (24-32) | Track Trigs | Trigger PLAYS FREE audio tracks control
A1 (33) | Seq stop | A#1 (34) | Seq Start/Stop | B1 (35) | Seq Start/Restart
C2 - G#2 (36-44) | Sample Trigs | Trigger Samples assigned to tracks (TRK DEFAULT)
C3 - G#3 (48-56) | MIDI Track Trigs | trigger PLAYS FREE midi tracks control
C4 - (60-71) | Track recorders/Pickup machine (*)
C5 - B5 (72-83) | Trigger track default sample chromatically, octave - 1
C6 - B6 (84-95) | Trigger track default sample chromatically, octave 0
C7 (96) | Trigger track default sample chromatically, octave + 1

C4 (60) | Combo rec
C#4 (61) | INAB rec
D4 (62) | INCD rec
D#4 (63) | SRC3 rec
E4 (64) | Pickup Play/Stop
F4 (65) | Multiply
F#4 (66) | Mute active track
G4 (67) | Cue active track
G#4 (68) | Active track up
A4 (69) | Active track down
A#4 (70) | Toggle Seq sync
B4 (71) | Toggle Seq sync+start

Warn me if there are mistakes ! :wink:


ahhh wonderful thank you!


Maybe you have an advice for what I’m doing wrong?

I have all tracks muted other than ‘T4’ (just to avoid confusion).

I also have AUTO Ch set to ‘9’. My midi keyboard is set to Midi Chan ‘9’.

‘T4’ is selected, it’s red. When I press keys on the external keyboard, trig ‘9’ lights up red, but no sound is coming out.

EDIT: I also have Audio CC In checked, and Audio Note In checked

EDIT 2: I now un-muted everything but ‘T1’, and the keyboard now triggers notes with the sound loaded on ‘T1’. Is it not possible to trigger notes with sounds on other tracks? Because it’s not working with any of the other ones.

Which keys are you pressing? The OT’s audio tracks only respond over a two-octave range (as listed in previous posts).

I just added this edit right when you posted:

I now un-muted everything but ‘T1’, and the keyboard now triggers notes with the sound loaded on ‘T1’. I can play it fine for two octaves. But is it not possible to trigger notes with sounds on other tracks? Because it’s not working with any of the other tracks.

Perhaps you know what the issue is?

These are the screenshots of my MIDI settings:

And my keyboard is set to MidiChan 9, like this:

It only triggers Track 1, no matter which track I choose on the OT.

(And actually even if I have the external keyboard set to a different channel, any channel at all, it still triggers Track 1 and only track 1. Even if the middi channel I choose for the keyboard is not the Auto Channel number)

This seems very odd, do you have some kind of midi monitor you can verify your controller is indeed sending on 9 and not 1 somehow?

That screen shot of your controller shows reference to ccs… Could there be a different setting for note output which may still be on channel 1?

:frowning: this is making me so sad, I tried what you said, suspecting the CC messages, created a new template for the MIDI keyboard, completely empty, and still no matter what I do , and what Midi Channel is set on the keyboard, the notes on Track 1 are being triggered.

Do you have a computer? You can download snoize for Mac or midiox for PC which are free midi monitors and you can verify your controller is sending on the right midi channel… It really seems like it’s sending on channel 1.
What is your controller by the way? How are you connecting it to OT?