Why is the Digitone clicking?

I didn’t see another post about this particular clicking. When I’m on the new default sound and play a note and quickly let go, it clicks as if a sample is being cut off before it hits 0. Obviously, these aren’t samples, but I can’t for the life of me figure it out.

Looks like you’ve got attack and release set to 0. This is expected behaviour, as it’s cutting the wave straight to 0, wherever it is in the cycle.

Set them to around 4–8; it won’t noticeably change the envelope behaviour, but the clicking will stop.


No option to reset the phase on notes?

Phase resets by default, but it doesn’t affect the release phase. It’ll still cut off instantly mid-cycle if your release setting is 0.


Yeah but it looks like he extends the release in the vid, and you say the phase of the cycle resets to zero in the attack stage as well?
Don’t have a digitone so don’t have a clue really


These values should be considered 0 if you are not specifically looking for it to click. And if you clear the page this is what it’s set to by default. The envelope is so quick it causes a transient. Nothing wrong, sometimes you are looking for that snappy envelope, and sometimes not.


Well, he’s adjusting the filter envelope, and not the amp envelope…

If you set the operators to reset at each trig then they’ll do just that… and that may also cause clicks if the sound is still going when you trig it again. I have a diagram in mind that may clear it up, but I’ve had a few drinks tonight so can’t be bothered making it right now… maybe tomorrow :smiley:

1 Like

Makes sense that it was the filter envelope not amp

1 Like

Thanks everyone. Def. meant to tweak the AMP envelope and not the FILTER envelope. Haha.

1 Like

So I tried mucking about with the ADSR and got rid of the clicking for a few sounds, but now I’m working on this bass sound that I want to have a bit of a thump at the beginning, but instead I get a more popping sound. When I bring up the attack, you lose the click, but then you’ll notice that there’s a click at the end note as it feeds back into the first note. If I can’t reliably not have these kind of clicks, I’m gonna have to send this thing back, regardless of how much I love the overall sound.

Along with that, I’m working on a pad. It’s 3 notes. Every other pattern cycle, it clicks. This is driving me bananas. Am I to expect clicking from this machine on a regular basis like this? Is it just inherent in the architecture or synthesis style?

There are a number of things you can do to reduce the clicking. It’s just the way the envelopes and the phase resetting work. It has a few different settings for different uses, and you have to be aware of them when making your sounds. I’ll try to explain it a bit more, maybe in a video, when I get my DN back (hopefully tomorrow!).

But in short, you can turn the amp env reset off, so repeated notes don’t completely retrig the envelope from zero. However, if you also have operator phase reset enabled, you may hear clicks. You just need to find a good balance between envelope settings and phase reset, for the sound you want to make.

Also, keep in mind that the same note repeated will use the same voice/cut itself off, even in poly mode.


I can see from the video that you are not using the modulation envelopes at all. These are key in FM synthesis and will help you with what you ask for. Try to study a preset that has the characteristics you are looking for and see how that creator has solved it.


I tweaked Envelope A which helped get rid of the the click on every note a bit, but still not enough that I’d be willing to use it in a track, but I guess @pselodux statement below explains why the last note is clicking into the first note. How am I supposed to do overlapping pad chords with the same note without them cutting off?

Unfortunately, this is cause for me to possibly return it. That’s disappointing because the sounds are really nice, but the clicking makes them undesirable for me. Damn. I’m gonna keep trying. Still have about 3 weeks to decide.

Also you are just using the filter envelope as an attack decay. You should try to use the full ADSR to get a punchier sound that still has a body to it.


I was trying to tweak the ADSR for it as that’s where I’ve been able to do it with the A4 and the Virus C. I actually based this sound off another preset I had loaded up.

1 Like

Turn off the AENR setting on the second AMP page. This stops the AMP envelope from resetting to 0 each time the same key is pressed. You may also want to turn off the ARST/BRST and PHRT settings, especially for pads.


Tried that. Still clicked because of the same note voice issue.

1 Like

@Olle, am I to understand that this clicking is unavoidable due to the fact that the same note being played sequentially will steal its own voice? Turning off the ARST and BRST as @pselodux suggests drastically changes the sound and it can’t be tamed with the filter envelope to sound the same. I feel like I have to be missing something.

EDIT: I tested my A4 in poly mode. When the envelope isn’t set to one of the RETRIG envelopes, it behaves as expected, the notes flow into each other. When set to RETRIG, there’s a very soft pop, which is expected.

Also, I noticed on the pad in the video, if I turn LEVB down all the way, no more clicks, but of course, then the sound is changed dramatically. Same if I turn the X/Y mix all the way to Y.

1 Like

It’s because the operator amount envelope is cutting in order to attack again. I agree it’s a bit of a sudden cut, but I guess it’s something you’re going to have to live with, unless Elektron implement the ability to make a slightly smoother transition back to the 0 point. I don’t think there’s scope to change the voice behaviour to allow for repeated notes to use different voices; tbh I’m not a big fan of that behaviour either. I think @Ess explained why it works that way in a previous thread (could be one of the bugs/suggestions threads).

As a workaround, perhaps try to mask that cut with delay/reverb? Or, a different voicing of the chord?

Actually, here’s an idea… save a copy of the sound, but use the sound settings menu to transpose it up/down an octave. Then, whenever you have two of the same chord in a row, use a sound lock to select the transposed sound, and “correct” it by changing to the octave needed in order to play the same note. I’m not sure if this would work, let me know!


This is a pretty smart workaround so I tried it out. It does even weird shit. Somehow it makes the envelopes act even odder. I made a sound. Saved it as Sound1, then copied it, moved it an octave up, and made it Sound2. Then I loaded both into the sound pool and did the p-locking as you suggested. Instead of clicks, it’s somehow changing the entire envelope to sound more like a bell instead of a pad.

You can hear the actual proper pad sound first, then you hear it get kind of weird like the air is being sucked out, then it keeps repeating the bell click sound. Sound1 is on trig 1, Sound2 is on trig 9.