Why no trig length on record?

so, eight years later. i still wonder. why doesn’t OT record trig length?

could this be changed?

I agree it would be very nice.


Added an option to select if note length should be recorded or not while inputting notes in the MIDI sequencer. The option is located in the PERSONALIZE menu.


Afaik on midi tracks, note length was always recorded, OS 1.40 introduced the option to turn it off.


So, is the OP talking about Audio or MIDI Tracks?

its because its different on the OT,
its the actual audio sample length rather than trig length. compared to other elektrons
maybe it cant work because it was designed to work with loops, im not sure

It’s possible to do with a midi processor and maybe Elektron will introduce the option to record note length as amp hold, we’ll see.

For playing slices from via midi, a midi processor was needed, the latest firmware introduced slices via midi amongst other features, so I wouldn’t say it’s absolutely impossible we’ll see that feature in a firmware update, but don’t count on it.

If you need it for the way you work, maybe consider buying a midi processor?


meaning for Flex audio tracks here

I think that’s feasible, as the note pitches are stored as Pitch plocks, Hold should be plockable the same way. And it works for midi tracks.

Yes I did it with a midi processor, mapping notes off to HOLD = min. In live rec it records a trigless with HOLD = min that stops the note.
Probably messy if you record several times.

1 Like

does this work for audio flex tracks also?

No, midi tracks, and it’s a new option to avoid length recording ! :content:

1 Like

And it worked consistently well? No issues whatsoever? I’ve only briefly tested it to confirm it worked.

First pass yes. A second pass would be problematic, previously recorded trigless with Hold = min stopping any note…

1 Like

It has to evolve, that’s not serious.
“The famous Elektron sequencer!”
Can’t record note length? :sketchy:

The way Octatrack records audio tracks notes would be ok for a drum machine, one shots only.


have asked this again to the team. it’s surely missed.

any new workarounds i’ve missed?

it seems the midi with cable internally is difficult…

can i use digitone as midi seq?

or maybe analog keys/four?