Connection failed between digitakt and computer


Today I have received my new digitakt and I am not being able to connect via transfer app to send samples or upgrade OS.

My setup is: as soundcard Focusrite clarett 4pre midi out port to midi in of the digitakt, and usb cable to the mac computer (El capitan). Message is “connection failed” or directly error within dropdown fields.

Any tip or clue?


Personally I find it better to use USB to transfer stuff to my Digitakt. It’s quicker. Don’t know if that helps.

1 Like

Exactly… here was the problem… I thought would be necessary connecting like C6 sysex manager, but not… the correct way to handle samples and upgrades it is USB, maybe it is a little confuse at the beginning.

Thank you.

can you explain this? can you transfer samples without using the app? transfer app stopped working for me after 1.03

I am not sure if you can transfer samples without the app but I upgraded operating system version from C6 sysex manager. Reading the manual I think is also contemplated that.

I had the same problem but it turned out to be I had the stupid midi cable in the wrong slot (it was a long night dont laugh, it happens! hehe) How is your MIDI CONFIG look like?



I think thats the only one that matters when connecting to it. If anyone knows better please chime in because I’d like to know too!

I’ve just got my Digitakt, I run latest OS 1.0.3 with latest Transfer for mac.

I have ports set for USB only.

And the computer can’t connect.

The manual is straightforward enough, but doing as it says simply won’t get any files into the machine…

the Transfer app is pretty buggy.
try restarting it - also found it has a better chance of connecting if you select the output port first, then the input port.
also, close it when not in use. It can get stuck in some background processing and consume a lot of CPU when it’s idle.

1 Like

i think I’ve tried all of those. Thing is, it seems to actually transfer files, but where do those go? Can’t see them in “incoming”.

have you tried renaming the destination folder at the bottom of the app?

1 Like

No. What should it be?

you can name a target folder there… DT should then create that folder when you send things…

1 Like

Cool, now it actually worked!

1 Like

Still no luck for me. Worked perfectly under 1, 1.01, 1.02, but 1.03 killed it for me. Tried everything. I even reinstalled OS X and booted with nothing attached aside from the DT and monitor.

So frustrating.

1 Like

same here going nuts

1 Like

What do you have on the machine so far? May have a limit with loops.
I had a few folders of 909 loops prob around 600 wavs all together
bit the bullet and cleared them out now it’s working. Maybe this info will help?

Only a couple folders worth of simple mono drum samples on it so far. That would be ridiculous if it were full. I’ll try deleting a folder of stuff and see.

Side note- perhaps it exists and I’ve yet to see it but is there any way to check memory status?

So I cleaned out some directories i had loaded up and nothing. What a waste of time! I’ve tried all the hints here. Ive even tried a different Computer. Wtf.

yeah it’s frustrating it started failing on me again …I have no idea? my guess is a bug fix will be up really soon. The joy of buying shit early lol

switched computers as well what a mess