Digitakt Bank Problems

I can see there are already a few posts concerning this topic but, maybe I’m just a little too stupid to understand them. I’m a complete NOOB with Elektron Hardware.

When I first plugged in my Midi instruments to the Digi, both Bank and Program changes worked like a dream. I installed the latest update 1.0.4. and now the Banks won’t change I’m left with just the Program changes.

Again I do apologize for being simple here but none of the other posts made much sense to me.


i usually

click digitakt forum group/heading or whatever its called .
click on magnifying glass (top right ish).
type in the most obvious heading to start with , i.e ‘bank’


it looks like a known issue with a work around…more info in the threads though…

The Tetra (like many other DSI, Clavia, Waldorf, Novation etc synths) only needs MIDI CC number 32 for Bank Select to work, whereas the Octatrack and Digitakt (apparently, from this topic) only send half of the MIDI Bank Select message (MIDI CC number 0), and not the half that the Tetra needs.


Could you describe your setup and what you are trying to achieve in a little more detail, please?

On my Blofeld the bank change only works if I then program change after that, like it catches up or something. Also I had lots of issues with it constantly changing the program and patch for no apparent reason, so I turned everything but notes of for now. I do hope they get the midi solid on this…

The MIDI Bank Select message only works if a Program Change message is sent immediately after the Bank Select message. Bank Select, on its own without a Program Change, should not work according to the MIDI standard.

The Digitakt will send MIDI Program Change messages when it changes its pattern, if configured to do so. Could that have caused the program changes on your Blofeld?


Also I had lots of issues with it constantly changing the program and patch for no apparent reason, so I turned everything but notes of for now.

Maybee you did a accidental live Recoding and recorder P-locks while changing the patch?
Did you try a new project?

Hi Peter,

At the moment from the Digitakt I have connected:

MOOG Sub 37
Roland TR-8
DSI Mopho x4 Polychained to a Tetr4
Roland SH-01A

I had tried some of the suggestions from other posts but still can’t get no Bank changes.
Thanks in advance


Thanks, I realised this after more reading.

They weren’t p-locked, just some odd behaviour going on.

1 Like

Have you tried just using cc32 with the corresponding 1-128 (or maybe it’s 0-127) being patch number? I saw this worked for someone else who was havin difficulty.

1 Like

The two Roland instruments have so few patches/patterns that they do not need to implement Bank Select.

The Moog and the DSI instruments have conventional Bank Select implementations, which the Digitakt (and Octatrack) do not currently address.

As @jefones hinted above, the workaround is to send a MIDI CC 32 message whose value is the number of the bank (0 or 1 for Sub37, or 0 to 7 for Mopho x4), immediately followed by the Program Change message.

Thanks I’ll try the Midi CC thing again, I had already tried this with no success.

(The Moog and the DSI instruments have conventional Bank Select implementations, which the Digitakt (and Octatrack) do not currently address)…

Why did it change banks before I updated the O.S. if your statement above is correct?


1 Like

I can’t be sure without knowing more about exactly what you were doing, which is why I asked whether you could share more details, but two things occur to me:

  1. With the Sub37 and bank changes, are you referring to the Moog use of the term “bank” by which the Sub37 divides its 256 sound locations into 16 banks of 16 patches? This usage of “bank” is different from the MIDI use of “bank”. In MIDI terms, the Sub37 has two banks of 128 patches. If you are in Sub37 preset banks 1-8 and you want to switch to another preset anywhere in banks 1-8 then you only need to send a MIDI Program Change message from the Digitakt; a MIDI Bank Select message would not be necessary. However, if you wanted to switch from a preset somewhere in sound banks 1-8 to a preset somewhere in sound banks 9-16 (or vice versa), you would need to send both the Bank Select message (MIDI CC 32) and the program Change message. The DSI synths have 128 programs per bank and their use of “bank” corresponds exactly with the MIDI use of the term.

  2. The second possible reason for problems that I can think of is the configuration of your system: you may have changed around your MIDI cables, or switched off reception of MIDI messages on your synth or (perhaps most likely) changed the MIDI channel assignments on your Digitakt’s MIDI sequencer tracks so that they no longer match the assigned MIDI channels on your synths.

1 Like

Thanks for taking the time to reply again, I do really appreciate it.

  1. Yes, I am referring to the Moog use of the term “bank” by which the Sub37 divides its 256 sound locations into 16 banks of 16 patches.

  2. Yes I have changed the Midi Channels on my DSI, but have made sure that the D.T. is sending to the correct channel as it does send change program changes. No cable changes have occurred :slight_smile:

Do you live in London, and if so can I invite you over to have a look lol? Or maybe we could do a Skype session where I can demonstrate what is what. That’s if my studio doesn’t blow away in tonights wind!

My pleasure.

So the checklist for testing communication between Digitakt and Sub37 is:

Connect MIDI Out of DT to MIDI In of S37.

Start a fresh project.
set OUT PORT FUNC to “MIDI”, and
set OUTPUT TO to “MIDI”.

Select a MIDI track.
On the SRC page, set the MIDI channel number to match the MIDI In channel number that is set on the S37;
set a value for PROG (remember to press and hold [FUNC] while pressing the Data Entry knob to first enable the knob).

On the Sub37:
Set the MIDI In channel number;
set RCV PGM CHG to “On”, and
set POLY NUMBER to “Off”.

When you play the DT’s pattern, the S37 should change its patch number to whichever program you selected on the DT.

What happens when you try it?

Hi Peter,

I followed your steps, I had to also enter Midi Config, Sync and switch on Prog Ch Send, then it worked. But now it will only let me scroll up to bank 8 and not up to 16 where my user presets are located. If I manually change it on the Sub 37, as soon as I touch the D.T. it changes the Sub 37 back to the preset it wants!

So, if I do the same for the DSI, it also works, but should I want to change banks on the DSI I have to do that with the Param 2 button on the DSI.

I guess it is highly unlikely that I would need to change bank during performance of a track, I just hope you can believe me that it did change banks on the DSI before the update.

1 Like

So If I now enable Bank on the DT and scroll to bank 4, now I can access me User presets… This is so confusing!

Great: now we know that your MIDI connections and settings are good.

OK. So here is where the workaround for the DT’s bad Bank Select message implementation comes in. If you want the S37 to switch to a program in the higher bank (9 to 16) locations, then put a MIDI CC message 32 with the value 1 immediately before the Program Change message on the relevant DT MIDI track. (I don’t know whether it would have to be parameter-locked (“p-locked”) on a previous step to the Program Change message.)

(To switch back to a patch location in S37 sound banks 1 to 8, you would have to precede the Program Change with a MIDI CC 32 message with value 0.)

The same MIDI CC 32 message workaround should work for the DSI gear, using a value in the range from 0 to 7 for the 8 banks of the Mopho x4.

I don’t disbelieve you, but I am slowly working you back to a state where that can be repeated.

Ok, so I know how to add the Midi CC32 in the amp Page, but have no idea what you mean with regards to adding a Value 0 or 1…

I feel your pain lol

1 Like

On the AMP page (“CC Select”) you choose the MIDI CC message number. It’s 32 for this purpose. That’s just a label for what this message should control: bank number.

Now on the FLTR page (“CC value”) you set the actual value that will be sent to the S37 using the corresponding knob to the previous step. The S37 accepts the values 0 (for its banks 1-8) or 1 (for its banks 9-16). Again, make sure you hold [FUNC] and press the knob to enable it before setting the value.

1 Like

Thank you for all your help Peter. I owe you a beer or 6 :wink: