MIDI in/out issue

In my current setup I have an external keyboard controlling the Model:Cycles, connected through the MIDI input jack. I also have the MIDI output connected to an external synth, T6 is configured to send MIDI notes out to the synth and everything seems to work.

The problem comes when I want to play the external synth using the external keyboard while recording what I’m playing on the Model:Cycles. The notes I’m playing do get recorded but they are not sent out to the synth, which means I can record a sequence and then play it back on the synth but I won’t be able to hear it while I’m playing.

Setting the MIDI output to “THROUGH” (instead of “OUT”) kinda solves the problem but not really: I can record a sequence while hearing what I’m playing but then the recorded sequence won’t play. After I record a sequence I have to change the MIDI output setting back to “OUT” to be able to hear what I just played, which is not ideal.

Anybody else had this issue? Is there a solution that I’m not seeing?

PS: this does not change the fact that I am in love with this machine, it’s sooooo fun to play with.

I was also surprised when first hooking up my MC that the midi wasn’t passed along when playing from an external keyboard. I couldn’t find any solution so far.

Hope elektron fix this. was really looking forward to sequence my modular from the m:c

same problem with me. keystep midi in, synth midi out.
any workaround?

I’ll throw my hat in the ring here too, keystep --> M:C --> 0-coast set up.

I have T6 on the M:C as a MIDI thru to the 0-coast.

When I play notes on the keystep, the 0-coast plays sound, but when I try to use the M:C sequencer (e.g. in quantized live-record mode), it doesn’t seem to record any of my notes into the M:C and doesn’t play them out on the 0-coast.

I’ve noticed 2 odd things that I wrote off to me being a novice and probably not knowing what I’m doing.

  1. When controlling my Cycles with a Keystep, if I’m browsing patches the Kèystep will not trigger those patches. It instead triggers the actual patch on the track. I understand why it might work like that but it’d be nice to turn the knob with one hand and use an actual keyboard to look for sounds.

  2. I have also run MC => Keystep => Sub Phatty => interface, so that I can use a track on the MC for the SP or use the arp/keys from the Keystep on the SP, while letting MC set clock.

With this setup if I run the MC on midi thru then clock seems to not get received by the Keystep and everything else down the chain, nor do they receive start/stop. Switching back to MIDI OUT it will work. Is that normal?

Hey hi
Same thing here with a Novation Launchkey mini 25 MK3

I was expecting to use the MODEL:CYCLES as a synth hub controlled by a clockless MIDI controller.

Hope this gets addressed.

Thanks &

I tried connecting my OP1> iPhone> elektron cycles> akai ax80 and couldnt seem to control the ax80 via OP1 despite being able to control the cycles. Tried setting it to thru and got the same results. Strange. Cmon elektron I really don’t wanna drop $100 on a midi router :frowning:

1 Like

Have you tried switching the polarity of the midi ports on the Cycles? In another thread, someone had similar problems with Thru, and it turned out to be the polarity. I believe it’s the last setting in Midi Port menu.

same issue here :slight_smile:

what i want to do:
play something with my keystep, record the midi on the MC and then send it to my microkorg so he plays it. Can someone help me? :slight_smile:

I’m having the same problem. Tried the polarity thing just yesterday-- I was like “ahhhhaaaaaaa I got it!” but it didn’t fix it. :frowning:

What is your setup? A few people have solved thru issues in different ways depending on what they aim to do/gear used.

The M:C is connected with USB MIDI.

With Ableton Live 10, I have two tracks: one is for audio in recording. The other is MIDI out to the M:C on MIDI track 1. Those work fine.

Then I also have a third track which is MIDI out to M:C but this time channel 11, to which i have my Particle 2 guitar pedal connected and set to channel 11. I would like to, at minimum, be able to change programs on the pedal-- maybe build an M4L editor as well or elsehow manipulate CCs on-the-fly.

With the M:C my current MIDI settings are:

Sync–>ClickIn–>ON, ClickOut–>OFF, PCHIN–>ON, PCHIN–>OFF
In Channel, T1-T6–>OFF, FXIn–>7, Auto In–>10, PCHIn–> 1
Out Channel, T1-T6–>OFF, FXOut–>7, Auto Out–> PCHOut–>8
Inp From–>USB, Out To–>M+U, Out Pol–>STD, Out/Thru–>THR

Panda to change programs on Cycles, correct? If so, wouldn’t the PCH IN need to be 11? I may have misread, but I think you want PCH IN to match the Panda channel.

i want LIVE 10 to change the programs on the panda, not the panda to do anything except receive.

I believe what you are experiencing is not the issue in this thread but something that is absent in all the elektron boxes. None of the elektron boxes function as a usb midi to din midi converter. This mean no elektron boxes pass the incoming usb midi to the din midi ports, making what you are trying to do not possible.

If you can din midi out of your computer into the model, then setting the port to thru should get you the desired results.


Well that sucks guess I gotta get a multi-MIDI interface because atm I only have one DIN in/out interface and it’s definitely taken. :frowning: If there’s a choice for out to DIN and USB and a choice for out/thru to THRU, that suggests this usage is possible, and honestly can’t see why it wouldn’t be. Not that my handwringing makes any difference.

Hey, I’m trying to use my Model Cycles to clock the Keystep to arp/sequence a 0-Coast - sounds like you’ve successfully done something similar. When I midi out the MC > keystep midi in the keystep flashes in time but won’t let me play the arp/sequencer (no sound). Any tips? Basically I want the MC to be a master clock but not sequence the keystep.

Hi, one year later is there any solution to this problem ? We only need a « out + thru » option actually.

Welcome to the forum!

Don’t expect a “solution” to this “problem”. The M:C is simply not designed to be a fully-featured MIDI sequencer.

1 Like

Thanks you !

I understand your point of view. But this is a little bit disappointing since the M:C is already capable of doing it, this is not a technical limitation. My current workaround it to live record in « THRU » then quickly switch to « OUT ».

I was looking for a device allowing me to make a small setup : a keyboard, an external synth and a groovebox/midi-looper.

This is my first Elektron box and I’m loving it. Do you know if Digitone/Digitakt or Octatrack could do that ?