Octatrack MKII crossfader - it often gets stuck

I mentioned this problem in a different topic, but I’d like to give this issue its own place to discuss, I hope you don’t mind.

So the crossfader on my device gets stuck easily if I don’t care much how I move it. The stick is very loose (I feel it less stable than that on MKI) and it has a very slight play upward and downward. And if I move the stick applying even a very little push upward accidentally it gets stuck and can’t be moved at all.

Do you also experience the same? Or can you move the slider smoothly even if you touch it a bit heavy (especially pushing upward a bit)? I don’t know whether the crossfader on my device is faulty and I should send it back to retailer (or for repairing to Elektron) or it is something I have to get used to.

I’ll test it tonight but it doesn’t seem to be the case on mine.


On mine it’s as smooth as… anyway it’s very smooth and doesn’t have the behavior you describe.


Was scratching with my OT mk II yesterday, absolutely no sticking. I fear your unit is faulty…


Oh no. I’m getting sad :slight_smile:

care to elaborate?


I experimented with the xfader curve adjustment methods like outlined in the xfader thread, and in the end I managed to find something workable. As in, tight enough cut that I could do pretty much everything except crabbing, chirps/flares worked aight. What followed was about an hour of mindless ahh / fresh cuttting freestyling… Next time when I have the chance I’ll figure out how to make the xfader cut on both sides :tongue:

so, to elaborate, I ran an audio signal from a turntable (line level tho) into AB inputs of the octa, set up a THRU track with scene configured for cutting and freeeeeeeeeeestyle’d. And I think I’ll be doing much more of this in the future, as a matter of fact I been toying with the idea that the “2 turntables and a mixer” paradigm could also become “1 turntable and an octatrack” for me in the future :tongue:


Mine is smooth as hell, but if i push it upwards or downwards really hard and then try to push it left-right, it will be a little resistance…

1 Like

I have to pull downward a bit to ensure its smoothness in every situation when moving :smiley:

Since the mk II is brand new, I’d contact elektron support and ask for service under warranty or a replacement. There should be none of this sort of sticking with the xfader.


cute but rather modest sounding compared to regular scratching IMO. Reminds me a lil of those controllerist scratches, although this actually sounds more musical than most

1 Like

My mk1 has a tad of resistance if I am pressing upward as well as left or right, the shaft that it’s on can move up or down just barely like a millimeter or two and I believe it just rubs the dust protector slightly and has some resistance… Mine won’t get stuck though, just more resistance…
If these have the same dust protector material I would check if that’s rubbing or getting caught…
It’s bugged me a little here and there but not enough to send it in, I might be able to open it up and tighten something on the shaft to fix the slight wobble and cure it…


Going off topic but yeah, vinyls are unbeatable.
Ot can mimic simple scratch. You’d need to map start/pitch/rate with crossfader position and speed to do better emulation.

So with MKII you think it’s better for scratching with a turntable ? Maybe more weight needeed…

I’ve never had an issue with this on the MKI (but I have a pretty light hand on the fader), but IIRC there’s a set screw for internal resistance adjustment in the fader (moves a magnet that changes how heavily it sits on its rails, I think). I’ve never opened mine up so I don’t know, bu0 tit’s possible that increasing the resistance a little might also help keep it from having enough play to drag on the sides.

Here’s a PDF with adjustment instructions for an Infinium optical crossfader, not sure if it’s the exact model used in the MKI or if it’s at all the same as the MKII fader, though:



I think this device is totally faulty. Scenes work strange. If track 3 or 4 are set to XLV MIN, it also fades out tracks 5 and 6 even if those are untouched by the scene. Reallly. I experience it with factory preset project as well as my own project copied over from OP1.


Hm. This may be related to older project. I can’t reproduce it in a brand new project created on 1.30. However older projects behave like this,

Try saving one, or rather “save to new” so you have your original backup…
Then reload it… Might work…
Maybe we have to wait for 1.3x for mk1 and save there first before bringing over…

Have absolutely no idea, just speculating…
Maybe someone official can chime in on this…

I’ve tried it. Didn’t help. I can’t work with my existing project this way :slight_smile: