Overhub Issues

I have a Macbook that doesn’t work with the supplied 3.0 USB cable. Will Overhub ever work with this? It is a very expensive paperweight at the moment.

try to plug it into ur usb2 port and then report back :slight_smile:

1 Like

Hahaha. :sob: :wink:

seriously , i was not joking


USB 3 is backwards compatible, if you connect a USB 3 hub to a computer with only a USB 2 connection it should still work as a USB 2 hub.

1 Like

TrabanT, My mid-2013 Macbook only has USB 3.0 (even though that’s supposed to be backwards compatible).

Simon, I had already contacted you about this. You told me that I should buy a USB 2.0 cable as I have one of the common Retina MacBooks that doesn’t work with the supplied cable. I am aware that new Overhub batches are being shipped with both cables because of this issue. I have looked for the appropriate cable but can’t find it locally and don’t feel like I should have to spend more money on something that already costs $65 US and doesn’t do what it is advertised as doing. You also told me that Elektron was working on the problem. Is there an update coming soon?

I see, I thought you meant that it wouldn’t work overall (in this thread), not specifically using more than one Analog machine (which is the original case iirc)

I’m sorry to hear that you have not been able to find a cable.
I’ll PM you to follow up on this.

Yes, it won’t work with even one machine. It worked fine before the last update.

Just bought an Overhub but can’t see AR & A4 in Overbrigde control panel? What’s wrong?

I notice that many places have the Overhub “Out of Stock”. With the compatibility issues with the chipset, I wonder if there is going to be a new reworked version that addresses the issue. I’m still waiting before buying an Overhub, even though I badly need a good hub for Overbridge use.

As I rebuild my studio I had no chance to try the overhub. Hope it works! :cry:

With the new Overbridge update adding the Heat, I find myself desperate for more USB connections. I need a hub. Of course the Overhub screams out as the potential answer, but I’m left wondering if they are still plagued by the same issues that had kept them from working properly up to now, or if all that has been addressed via updates or perhaps changes to the Overhub’s electronics / manufacturing. I haven’t seen anything to indicate the latter, and I am not looking to toss any money into a pit if I can help it. At this point I’m unsure how to proceed, being unsure about the Overhub’s performance… and the alternative option I’m looking at, I am not even sure if it has MTT https://www.amazon.com/gp/product/B00GSLMTQ8/ref=ox_sc_act_title_2?ie=UTF8&psc=1&smid=A294P4X9EWVXLJ

Mine now works perfectly (with the USB3 cable), since I moved from El Capitan to Sierra.


Hmm. So you have to switch out the USB cable between the Overdub and your Mac for a USB3 cable for it to work properly… on Sierra?!?

Sierra fixes some fundamental USB issues. Various manufacturers have confirmed that.

I’m using a USB3 cable (supplied with Overhub), but USB2 cable might work too.


No problems since my upgrade to Sierra - I use Analog Rytm, Analog Four and Analog Heat all in Overbridge with Overhub. Whatever the problems were in El Cap seem to be fixed.


Alright. I think I am going to trust you guys and take a leap of faith. I’m ordering the Overhub, and going to upgrade to Sierra this weekend. This could go terribly, so high hopes that everything ends up working properly… especially Overhub.

Remember to re-install Overbridge after the upgrade for more stability.



I now have my SECOND overhub in less than a week

The first one’s USB to computer jack had poped it’s solder joints internally, If I held it at a very specific angle it worked, but because I need my hands for things other than holding Overhub and it’s USB cable, back to the shop it went

I returned it, was given a new one today and apon brining it home was surprised by the fact that IT DOESN’T WORK AT ALL

I have done the usual raindance (differnt ports, configs, gear ect.) but although the green light is lit, this hub does not work, I am on an early 2011 MBP running El Capitain OSX 10.11.6

I am not interested in updating my Mac OS as the number of problems it could potentially cause is well know, I would not consider this to be a reasonable fix for Elektron to suggest now as 1. The other one DID work, though it was unusable due to lack of QC 2. Nowhere on the box does it say “Compatable only with…”

Some one early said “I love Elektron” to that person I would say give your head a shake, they don’t love you. This is a company with whom you do business with when you buy thier products, they are not the source of your identity, if they have started selling products that do not work as intended, then I call them a dishonest company .

I suppose I will contact support, but if I have to go back and return ANOTHER overhub than that is a lot of my time they have wasted

If this Overhub goes back because Elektron is selling products that do not work as intended, then the Analog Keys I bought it with goes back as well

I will keep my Octatrack although come to think of it, that still has bugs as well…

Hmm, it would seem Elektron does not respect thier customers, bringing defective items to market is proof of that

Fine by me, pleanty of other places for me to spend my money

Am I correct in concluding this Overub is a “Hit or miss” type of thing? Where it works for maybe half the people who buy it?

Is there some fix I have not yet discovered in my 3 hours of research?

Please let me know if I’ve missed something

1 Like

I’d suggest you don’t rant at support and imply they’re a ‘dishonest company’ or that they ‘do not respect their customers’ because this is simply not true or fair or constructive either there or here to be honest.

You may have had some bad luck on one shop bought product (therefore raising the possibility of ambiguous usage history) and possibly even two, but you are an exception in terms of your experience judging by the comments here

It’s just a hub, you could try it on a number of devices to see if it’s working, if it’s not and it’s a quality control issue then I’m sure you’ll be offered the right solution … but please keep in mind that this is predominantly a user forum, it’s all very well reporting your issues but please do so with some respect and resist suggesting that people should ‘shake their heads’ just because they have a good experience … sure, you’ve had a rotten bit of consumer luck, but keep it in perspective

better explain to support more clearly how you’ve established that it is indeed not working, the device connected, the current draw etc